Results 1 to 8 of 8
  1. #1
    4 Star Lounger
    Join Date
    Feb 2002
    Location
    Auckland, New Zealand
    Posts
    543
    Thanks
    56
    Thanked 0 Times in 0 Posts

    xReference problems (MSO2003 winxppro)

    Hi

    I am having difficulty getting a cross reference to work. The document is created from a template that is populated from our SQL database. For some reason I cannot get the persons name to be repeated when requested by a cross reference field.

    Can anyone help. I am sure it is very simple.
    Attached Files Attached Files
    cheers

    Phil Carter

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: xReference problems (MSO2003 winxppro)

    Your bookmark refers to an insertion point only, not to a piece of text. You can see this by ticking the check box labeled "Bookmarks" in the View tab of Tools | Options...
    So the cross reference to the bookmark doesn't display any text. If you redefine the bookmark to span the name and update the cross reference, it will work the way you intended.

  3. #3
    4 Star Lounger
    Join Date
    Feb 2002
    Location
    Auckland, New Zealand
    Posts
    543
    Thanks
    56
    Thanked 0 Times in 0 Posts

    Re: xReference problems (MSO2003 winxppro)

    Hans thanks for that

    How do I create a an enclosed bookmark? The problem I have is that it is the retrieved text that I need to use for the Ref field.

    cheers
    cheers

    Phil Carter

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: xReference problems (MSO2003 winxppro)

    Select the text you want to refer to and then select Insert | Bookmark...

  5. #5
    4 Star Lounger
    Join Date
    Feb 2002
    Location
    Auckland, New Zealand
    Posts
    543
    Thanks
    56
    Thanked 0 Times in 0 Posts

    Re: xReference problems (MSO2003 winxppro)

    Hans

    I undstand that, but in setting up the field there is nothing to refer to. The bookmark, in this case "bmk002AuthorisedRepName", is just a place holder.

    cheers
    cheers

    Phil Carter

  6. #6
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: xReference problems (MSO2003 winxppro)

    Whatever process populates the document is going to have to extend the bookmark to cover the entire data.

  7. #7
    4 Star Lounger
    Join Date
    Feb 2002
    Location
    Auckland, New Zealand
    Posts
    543
    Thanks
    56
    Thanked 0 Times in 0 Posts

    Re: xReference problems (MSO2003 winxppro)

    Jefferson hi

    This is the XML code used to extract the data and populate the bookmark;

    <content type="expression" id="bmk002AuthorisedRepName" locationtype="bookmark" locationname="bmk002AuthorisedRepName" function="insertafter" value="Trim(AU.Program.AuthorisedRep.minPerson.Nam e.Prompt)" object="objAUJob" />

    I have tried replacing the "function="insertafter"" with "function="Insertbefore"" but this does not seen to make any difference.
    cheers

    Phil Carter

  8. #8
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: xReference problems (MSO2003 winxppro)

    This is unfamiliar to me... I haven't used any XML features of Word 2003 (or even its merge features); I'm almost exclusively still using Word 2002. Unless you have an option similar to "insert into," then perhaps some separate VBA procedure might be required. It would be convenient if your document contained an unusual character after the bookmark so that the inserted information could be bracketed by the bookmark (before) and the unusual character (after). In that scenario, VBA could be used to extend the bookmark up to the unusual character and to then to delete that character from the document. I'm not sure how this might be integrated with your existing processes.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •