Results 1 to 10 of 10
  1. #1
    Gold Lounger
    Join Date
    Feb 2004
    Location
    Cape Town, RSA
    Posts
    3,444
    Thanks
    0
    Thanked 1 Time in 1 Post

    NumLock disabled when Logging On. (Win XP (Prof))

    Hi,

    Can anyone tell me how to ensure that the NumLock option activates automatically when I log onto my profile on my work PC. Currently, when I log on, the NumLock is off, and (though a small issue), its irritating to have to activate it before I can use the numeric keypad!

    TIA
    Regards,
    Rudi

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: NumLock disabled when Logging On. (Win XP (Prof))


  3. #3
    Gold Lounger
    Join Date
    Feb 2004
    Location
    Cape Town, RSA
    Posts
    3,444
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: NumLock disabled when Logging On. (Win XP (Prof))

    <img src=/S/thankyou.gif border=0 alt=thankyou width=40 height=15>
    Regards,
    Rudi

  4. #4
    Gold Lounger
    Join Date
    Feb 2004
    Location
    Cape Town, RSA
    Posts
    3,444
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: NumLock disabled when Logging On. (Win XP (Prof))

    Hi Hans,

    I am now at the PC with this NumLock isssue. I went into the registry and attempted to change the value to 2. When i choose OK, it gives this error? Any ideas?

    PS: This is NOT a major problem I have, so please do not get tied down with this...( I am sure others have more NB problems than this!)
    Regards,
    Rudi

  5. #5
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: NumLock disabled when Logging On. (Win XP (Prof))

    Apparently you don't have sufficient permissions to edit the registry settings for the default user. Can you edit the InitialKeyboardIndicators value in HKEY_CURRENT_USERControl PanelKeyboard? That should turn on NumLock after you have logged in.

  6. #6
    Gold Lounger
    Join Date
    Feb 2004
    Location
    Cape Town, RSA
    Posts
    3,444
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: NumLock disabled when Logging On. (Win XP (Prof))

    Yes...this is accepted, and I changed it to 2. But as you say, it only switches NumLock on after I log on. I can live with this! <img src=/S/wink.gif border=0 alt=wink width=15 height=15>

    PS: Can this setting be changed in the CMOS Setup. I type under correction, but I recall this setting is available there too? I may have done this years back on my home PC. But I have lost all that hardware expertise over time!
    Regards,
    Rudi

  7. #7
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: NumLock disabled when Logging On. (Win XP (Prof))

    I wouldn't be surprised if Windows XP overrides the CMOS setting, but I know very little about this.

  8. #8
    Gold Lounger
    Join Date
    Feb 2004
    Location
    Cape Town, RSA
    Posts
    3,444
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: NumLock disabled when Logging On. (Win XP (Prof))

    No hassles....(as I said, my tampering in CMOS was a long time ago!)
    Tx for the assistance again! I am happy with the current settings.
    Cheers
    Regards,
    Rudi

  9. #9
    Plutonium Lounger Leif's Avatar
    Join Date
    Dec 2000
    Location
    U.K.
    Posts
    14,010
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: NumLock disabled when Logging On. (Win XP (Pro

    From memory, I've found that ideally you need to set Numlock in both CMOS and the registry on some machines. It should come on *before* you log on if both are set.

  10. #10
    Gold Lounger
    Join Date
    Feb 2004
    Location
    Cape Town, RSA
    Posts
    3,444
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: NumLock disabled when Logging On. (Win XP (Pro

    Hmm...I will need to experiment with that on my work PC. I'll give it a try when I reboot the machine!
    Tx for your input.
    Regards,
    Rudi

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •