Results 1 to 3 of 3
  1. #1
    New Lounger
    Join Date
    Mar 2003
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Macros not working after XP upgrade (XP)

    Since upgrading Office 2000 to XP, my extensive collection of Word macros no longer works. They were neatly stored in a template, macros.dot, that is in crogram filesmicrosoft officeoffice10startup, and accessed via buttons on a custom toolbar.

    But now, when I click one of the buttons, I get the warning that "The macro cannot be found or has been disabled because of your Macro security settings".

    This persists even if I set macro security to Low. It also persists if I use Tools|Customize to browse to one of the macros and create a new toolbar button for it.

    What am I missing here...?

    Thanks

    Ed

  2. #2
    New Lounger
    Join Date
    Mar 2003
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Macros not working after XP upgrade (XP)

    Looks like I solved this on my own!

    I created a digital certificate using the makecert.exe Office tool, signed the macros in the macros.dot template, quit Word and restarted. It then asked me whether I wanted to trust myself (!), and then allowed the macros to run.

    Ed

  3. #3
    Silver Lounger Charles Kenyon's Avatar
    Join Date
    Jan 2001
    Location
    Sun Prairie, Wisconsin, Wisconsin, USA
    Posts
    2,048
    Thanks
    124
    Thanked 119 Times in 116 Posts

    Re: Macros not working after XP upgrade (XP)

    I don't know Word 2002 but Word 2000 has a setting for whether or not to automatically trust items installed templates and Add-Ins. This is a checkbox on the Tools => Macros => Security => Trusted Sources (tab) dialog box.
    Charles Kyle Kenyon
    Madison, Wisconsin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •