Results 1 to 3 of 3
  1. #1
    Lounger
    Join Date
    Jun 2004
    Posts
    40
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Record is Deleted (Access 2000)

    We have a series of forms that are called one after each other to form a data entry Wizard. The "wizard" is being used by up to 5 users at once. However, one or more of the users is experiencing an issue moving between 2 of the forms - lets call them step 6 and step 7.

    Although the data for both forms is called in exactly the same way (a simple query on one table), when step 7 form is loaded, the database reports "Record is Deleted" and #Name appears in every field on the form. However, investigation has shown that the record has not been deleted and if the user goes back to step 6, the previous data entered is still there. Then, if the user moved forward again to step 7, the form allows the entry of more data.

    This problem occurs once in about every 20 times. Both forms involved are simply flat forms with no tab cards or sub forms involved. We have amended the properties of all the forms involved so that Record Locks is set to "No Locks", but this hasn't solved the problem.

    Has anyone else experienced a similar problem?

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Record is Deleted (Access 2000)

    It might be a timing problem. Perhaps the relevant record hasn't been fully saved yet when the next form is opened. Have you tried saving the record explicitly before opening the next form?

  3. #3
    Lounger
    Join Date
    Jun 2004
    Posts
    40
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Record is Deleted (Access 2000)

    Many thanks Hans.... we'll look into maybe adding a save command to the previous form(s).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •