Results 1 to 5 of 5
  1. #1
    2 Star Lounger
    Join Date
    Jun 2002
    Location
    Loudon, New Hampshire, USA
    Posts
    125
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Phone Mask (Access 2003/Windows XP)

    Hi,
    On a modify form, no adds or deletes, I am having a problem with phone number edit masks. I have a name field followed by a phone number field and a cell phone number field. Then a Second name field follows the cell number, and it in turn is followed by another phone number and cell phone number. All the numbers are ten characters. The edit mask is '!(999")"000-0000;;_' for each phone number. The first phone number works fine, but the cell phone for name one and the Phone number and Cell phone number for name two do not work. On some occasions I enter ten numbers into the field and I get an error message - The value you entered isn't appropriate for the Input Mask "!(999")"000-0000;;_' specified for this field. I have checked the first phone number against the other phone numbers and I do not see any difference. I hope someone has an idea for I am stymied.
    Fingers crossed,
    Sarge

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Phone Mask (Access 2003/Windows XP)

    Try to see if there are differences in the other properties of the text boxes or the underlying fields in the table.
    An alternative would be to create a separate table with a separate record for each phone number.
    If you wush, you can post a stripped down copy of your database. See <post#=401925>post 401925</post#> for instructions.

  3. #3
    Super Moderator
    Join Date
    Jun 2002
    Location
    Mt Macedon, Victoria, Australia
    Posts
    3,993
    Thanks
    1
    Thanked 45 Times in 44 Posts

    Re: Phone Mask (Access 2003/Windows XP)

    It is easy to not see a minor difference.

    I would copy the mask from the field that does work to the ones that do not work, both on the form and in the table.(or remove the mask from the table if you have them there as well.)
    Regards
    John



  4. #4
    2 Star Lounger
    Join Date
    Jun 2002
    Location
    Loudon, New Hampshire, USA
    Posts
    125
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Phone Mask (Access 2003/Windows XP)

    Thanks for the suggestion, but I tried that and it did not work. I still do not know why I am having this problem with the wizard mask. However, I coded a new mask, '"("999")"999"-"9999;;_' and it seem to work. Why, I have know idea, but I am happy with the results.
    Thanks again,
    Sarge

  5. #5
    2 Star Lounger
    Join Date
    Jun 2002
    Location
    Loudon, New Hampshire, USA
    Posts
    125
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Phone Mask (Access 2003/Windows XP)

    HansV,
    I used Snagit to Print my code and matched the different phone numbers, no differences. Even if I pared down the code and tables, it would be too big a zip file and It is Access XP and will not let me go back to 97. As I told John, I did start play around some more and created my own mask. ( "("999")"999"-"9999;;_) Using it instead of the one created by the wizard, seems to have banished my problem, fingers crossed. I have no idea why, but I am happy that my problem seems to be behind me. Thanks again for your help.
    Sarge

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •