Results 1 to 4 of 4
  1. #1
    2 Star Lounger
    Join Date
    Mar 2002
    Posts
    164
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Unknown Function (2003)

    This is pretty strange. The following function has been working for me for the past 6 months. Recently, I decided to check the tables, and noticed new records in my tables were not reflecting the user and date/time who added it. Additionally, my users get a message like so...

    Unknown function Environ$ in validation expression or default value.

    The tables have the following set as a default value...Now() and =Environ$("UserName")

    It works fine on my machine, and I have Access 2003. They were just updated to 2003 as well, and that's when we started having difficulties. Any advice? Thanks in advance!

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Unknown Function (2003)

    It has to do with the enhanced security in recent versions of the Jet Engine. Environ is not considered a "safe" function. See How to configure Jet 4.0 to prevent unsafe functions from running in Access 2003 for a description of the problem and how to bypass it.

  3. #3
    2 Star Lounger
    Join Date
    Mar 2002
    Posts
    164
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Unknown Function (2003)

    Thanks! Another question. Is there a "safe way" to record the user versus using the previous function.

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Unknown Function (2003)

    The GetNetUser function from <post:=446,010>post 446,010</post:> shouldn't cause security problems.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •