Results 1 to 3 of 3
  1. #1
    5 Star Lounger
    Join Date
    Jan 2001
    Location
    Vancouver, Br. Columbia, Canada
    Posts
    632
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Turn off automatic formatting (XL 2003 SP2)

    I've been bitten by this automatic "helpful feature" a few times, and decided to track down what's going on. Turns out that XL decides for itself that some data I enter should be converted to a percentage and that screws up my worksheet.

    To demonstrate with a clean spreadsheet.

    - enter numbers in three vertical cells (this behaviour does not appear with fewer than three rows of data)
    - enter a number in the fourth row -- everything is proper

    - enter numbers into three vertical cells in a new column
    - select the numbers, and apply the Percent format with the toolbar button
    - enter a number in the fourth or fifth row
    - XL changes the number to a Percent format

    What's worse is that the cell's content is actually changed by a factor of 100. It's not just a formatting problem.

    - enter numbers into three vertical cells in a new column
    - select the numbers, and apply the Percent format with the toolbar button
    - enter a number in the sixth or subsequent row
    - XL leaves the formatting and cell contents unaltered

    Looking thru Tools > Autocorrect options, I found the "Include new rows and columns in list" setting and turned it OFF, to no avail. Did not find any other setting that seemed associated with this behaviour, so is there any way to disable this inconsistent behaviour? I would be quite happy for XL NOT to apply any automatic formatting, and let me decide for myself when I want a cell formatted.

    <rant>I **really** wish that Microsoft would stop adding these erratic behaviours to its products. Is it too much to ask for consistent behaviour?</rant>
    --------------------------------------------------
    Jack MacDonald
    Vancouver, Canada

  2. #2
    Uranium Lounger
    Join Date
    Jan 2001
    Location
    South Carolina, USA
    Posts
    7,295
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Turn off automatic formatting (XL 2003 SP2)

    That is Excel trying to be smarter than it actually is. Go to Tools/Options and click on the Edit tab. Uncheck the box next to "Extend list formats and formulas."
    Legare Coleman

  3. #3
    5 Star Lounger
    Join Date
    Jan 2001
    Location
    Vancouver, Br. Columbia, Canada
    Posts
    632
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Turn off automatic formatting (XL 2003 SP2)

    Thank you.
    --------------------------------------------------
    Jack MacDonald
    Vancouver, Canada

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •