Results 1 to 5 of 5
  • Thread Tools
  1. 4 Star Lounger
    Join Date
    Jun 2001
    Location
    Edinburgh, Midlothian, Scotland
    Posts
    492
    Thanks
    0
    Thanked 0 Times in 0 Posts

    'My Pictures' Folder missing (XP SP2)

    I'm having problems running the new Adobe Lightroom product. Apparently if "My Pictures" is not present it does not work.

    I've tried to set an entry at

    HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVe rsionExplorerShell Folders

    When I reboot however this setting in the Registry is lost.

    I've also checked TweakUI and "My Pictures" is not listed in the Special Folders section.

    Anyone got any suggestions please

    Colin

  2. Subscribe to our Windows Secrets Newsletter - It's Free!

    Get our unique weekly Newsletter with tips and techniques, how to's and critical updates on Windows 7, Windows 8, Windows XP, Firefox, Internet Explorer, Google, etc. Join our 480,000 subscribers!

    Excel 2013: The Missing Manual

    + Get this BONUS — free!

    Get the most of Excel! Learn about new features, basics of creating a new spreadsheet and using the infamous Ribbon in the first chapter of Excel 2013: The Missing Manual - Subscribe and download Chapter 1 for free!

  3. Uranium Lounger
    Join Date
    Mar 2001
    Location
    New Jersey
    Posts
    6,684
    Thanks
    1
    Thanked 11 Times in 11 Posts

    Re: 'My Pictures' Folder missing (XP SP2)

    Sure. Right click on the Start button and select Properties. Then go to the Start Menu Tab and click on the Customize button. Next click on the Advanced tab and then scroll down the Start Menu items list to My Pictures and put the tick in the appropriate circle to suit your needs (Display As Menu should do what you need). HTH <img src=/S/smile.gif border=0 alt=smile width=15 height=15>
    <IMG SRC=http://www.wopr.com/w3tuserpics/DocWatson_sig.gif>

  4. Silver Lounger
    Join Date
    Apr 2001
    Location
    New York, New York, USA
    Posts
    2,328
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: 'My Pictures' Folder missing (XP SP2)

    When I reboot however this setting in the Registry is lost.

    Be sure that your userprofile allows you to modify the registry.
    Restore the string value in

    HKEY_USERS.DEFAULTSoftwareMicrosoftWindowsCurrentV ersionExplorerUser Shell Folders

    Name: My Pictures
    Value: %USERPROFILE%My DocumentsMy Pictures

    and in

    HKEY_USERS.DEFAULTSoftwareMicrosoftWindowsCurrentV ersionExplorerShell Folders

    Name: My Pictures
    Value: (blank)

    You may also restore these string values in all existing profiles, as
    HKEY_USERSS-1-5-18...
    HKEY_USERSS-1-5-21-1078081533-515967899-839522115-1003...
    etc.

    Note: If any of userprofiles uses another folder as special "My Pictures" folder, modify corresponding string value, as in this example:

    HKEY_USERSS-1-5-21-1078081533-515967899-839522115-1003SoftwareMicrosoftWindowsCurrentVersionExplorer User Shell Folders
    Name: My Pictures
    Value: D:My DocumentsMy Pictures
    HKEY_USERSS-1-5-21-1078081533-515967899-839522115-1003SoftwareMicrosoftWindowsCurrentVersionExplorer Shell Folders
    Name: My Pictures
    Value: D:My DocumentsMy Pictures

  5. 4 Star Lounger
    Join Date
    Jun 2001
    Location
    Edinburgh, Midlothian, Scotland
    Posts
    492
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: 'My Pictures' Folder missing (XP SP2)

    Thanks for the two replies. So far I've only had a look at Doc Watsons reply as this has thrown up some questions. So I'll concentrate on it first, and look at the registry questions later ( although I understand they may be linked)

    Initially, I was a bit puzzled by the instructions given in this post. Then I twigged. I use the Classic start menu, and the Options here are totally different. However, I changed to the new version and changed the settings, but it doesn't make the My Pictures appear (in fact it was already selected as "Display as Link".) I then noticed the same applied to "My Music" this was also selected as "Display as Link" and yet didn't appear on my start menu.

    I checked the registry, and neither My Pictures or My Music has an entry at the ShellFolders link I posted above (nor does My Videos.

    I do have my "My Documents" drive set to Data as this means I can back up my E-drive easily, it also means I can re-install Windows if required without losing data files.

    It does look as if something is missing from my install. I've never really tried anything other than a new install. But is there not a way to repair without the destructive force of a re-install.

    Thanks again.


    Colin

  6. Uranium Lounger
    Join Date
    Mar 2001
    Location
    New Jersey
    Posts
    6,684
    Thanks
    1
    Thanked 11 Times in 11 Posts

    Re: 'My Pictures' Folder missing (XP SP2)

    You might want to take a look at Kelly's Korner for a registry fix for this one. I've never seen a situation where changing those settings didn't restore those folders.
    <IMG SRC=http://www.wopr.com/w3tuserpics/DocWatson_sig.gif>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •