Page 1 of 2 12 LastLast
Results 1 to 15 of 17
  1. #1
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Swanzey, New Hampshire, USA
    Posts
    1,707
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Some programs not starting on bootup (XP Home SP-2)

    Win XP Home w/all current updates. This is a problem I have not encountered before and I'm baffled as to why it is happening. For no apparent reason, I have about 4 or 5 programs that no longer start/run at bootup, e.g., InCD, CursorXP, TrueImageMonitor.exe (process), etc. After the machine boots and everything loads, I can manually start them and everything works fine. In fact, the machine runs great in all other respects. I checked Startman and some of the programs are missing but the others are there and show as enabled to run at startup . I've gone into the Options of each program that have them and made sure that "Run at startup" is enabled.

    I've uninstalled and re-installed some of these programs but that didn't help.

    I've run chkdisk, run antispyware and antivirus scans and everything comes back clean.

    Any ideas about any of the above?? <img src=/S/shrug.gif border=0 alt=shrug width=39 height=15>

    Jeff
    Jeff
    simul iustus et peccator

  2. #2
    Uranium Lounger viking33's Avatar
    Join Date
    Jun 2002
    Location
    Cape Cod, Massachusetts, USA
    Posts
    6,308
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Some programs not starting on bootup (XP Home SP-2)

    Jeff,
    Maybe a better place to look would be in AUTORUNS that has a more comprehensive list of start ups?
    BOB
    http://lounge.windowssecrets.com/S/flags/USA.gif http://lounge.windowssecrets.com/S/f...sachusetts.gif


    Long ago, there was a time when men cursed and beat on the ground with sticks. It was called witchcraft.
    Today it is called golf!

  3. #3
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Swanzey, New Hampshire, USA
    Posts
    1,707
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Some programs not starting on bootup (XP Home SP-2)

    Thanks Bob, I do have Autoruns and briefly perused the very long list of items but couldn't see anything that meant much. The programs that aren't being loaded at startup used to be listed in "Startman" but are no longer there. Something has happened and I'm simply hitting a wall trying to figure out what that was.

    Jeff
    Jeff
    simul iustus et peccator

  4. #4
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,592
    Thanks
    5
    Thanked 1,059 Times in 928 Posts

    Re: Some programs not starting on bootup (XP Home SP-2)

    Sometimes a re-boot between uninstall and reinstall helps even though it may not be required. Same with changing settings.

    Joe
    Joe

  5. #5
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Swanzey, New Hampshire, USA
    Posts
    1,707
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Some programs not starting on bootup (XP Home SP-2)

    Joe,

    Yes, I am aware of that and did exactly that; rebooted between uninstallation and re-installation of the programs that aren't starting on bootup.

    So again, with the hopes that this might spark something.. e.g., I uninstalled CursorXP, rebooted and re-installed it. The program works fine. I checked in Startman and msconfig/Startup and both showed CursorXP as being enabled to run at Startup. So, I rebooted and CursorXP did not load. Looking again in those two locations showed that CursorXP was not listed any longer in the list of startup items. I can repeat this for each of the problematic applications. Soooo, evidently, something is removing these particular items from the startup process. I suspect it is a system file? but I may be way off track.

    I'm wondering now if running "sfc /scannow" might correct the situation?? I do have a backup image I could restore from the 13th, but I would rather not until I've exhausted all other attempts to correct the situation.

    Jeff
    Jeff
    simul iustus et peccator

  6. #6
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,592
    Thanks
    5
    Thanked 1,059 Times in 928 Posts

    Re: Some programs not starting on bootup (XP Home SP-2)

    Are you running Windows Defender orany other program which monitors changes to key system settings?

    Joe
    Joe

  7. #7
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Swanzey, New Hampshire, USA
    Posts
    1,707
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Some programs not starting on bootup (XP Home SP-2)

    <P ID="edit" class=small>(Edited by Pilgrim on 17-Aug-06 19:52. )</P>Joe,

    Not at this time. I was running Outpost Firewall Pro (Beta) and uninstalled it to see if perhaps it was behind this anomaly. But the problem remains. What I am trying to do now is locate the Registry entries for some of these programs and see if they are removed on bootup, e.g., for CursorXP, the Registry entry where it is listed to run at startup is: HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVe rsionRun. If after I reboot, this String is missing, then at least I would then know a little more. Of course, WHY the string is removed and by WHAT is going to be the hard part. <img src=/S/laugh.gif border=0 alt=laugh width=15 height=15>

    Jeff

    ADDENDUM: Okay... rebooted and immediately checked the Registry after the programs didn't start. And, sure enough that particular Key was empty. All the entries for those programs which are to run at startup were missing. Unless my ignorance is at fault, this doesn't seem to be right.

    Any help from this further information??
    Jeff
    simul iustus et peccator

  8. #8
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,592
    Thanks
    5
    Thanked 1,059 Times in 928 Posts

    Re: Some programs not starting on bootup (XP Home SP-2)

    You said the string is missing. Do you mean the whole key or the data? Have you run a complete A/V scan? How about spyware scans?

    Joe
    Joe

  9. #9
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Swanzey, New Hampshire, USA
    Posts
    1,707
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Some programs not starting on bootup (XP Home SP-2)

    <hr>You said the string is missing. Do you mean the whole key or the data? Have you run a complete A/V scan? How about spyware scans?<hr>
    Just the data (strings) that appears on the right. Sure, I've run a complete system scan with both Kaspersky and Spybot S&D. As you might expect on "my" machine, it is prissy clean. <IMG SRC=http://www.the-highway.com/Smileys/giggle.gif>

    Jeff
    Jeff
    simul iustus et peccator

  10. #10
    Uranium Lounger viking33's Avatar
    Join Date
    Jun 2002
    Location
    Cape Cod, Massachusetts, USA
    Posts
    6,308
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Some programs not starting on bootup (XP Home SP-2)

    jeff,
    Just had the thought. Have you checked for any Rootkits hiding away on your system?
    From what I have read on them, they will defy most AV or anti-spyware detections.

    It sure sounds like you have SOME kind of nasty doing a job on you.

    There is a list of Anti-Rootkit detectors listed, some freebies, HERE
    BOB
    http://lounge.windowssecrets.com/S/flags/USA.gif http://lounge.windowssecrets.com/S/f...sachusetts.gif


    Long ago, there was a time when men cursed and beat on the ground with sticks. It was called witchcraft.
    Today it is called golf!

  11. #11
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Swanzey, New Hampshire, USA
    Posts
    1,707
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Some programs not starting on bootup (XP Home SP-2)

    Thanks for the link, Bob. I ran the one from SysInternals and nothing was found. So, I'm going to assume that I don't have a rootkit on the system. I'm guessing, but I am fairly certain that the problem began when I uninstalled OmniPage Pro 14. Evidently, if my guess is correct, that a necessary file was removed during the uninstall process. I doubt I'll ever be able to find out if this was the case, and if it was, what file(s) were wrongly deleted or corrupted.

    At this point I'm debating on whether to do a "Repair Install" of XP to see if that will rectify this annoying problem. I really don't want to format the drive and do a total reinstall of the O/S and everything else. That would take days. <img src=/S/drop.gif border=0 alt=drop width=23 height=23> Maybe as sometimes happens, the problem will correct itself over time. <img src=/S/rofl.gif border=0 alt=rofl width=15 height=15>

    Jeff
    Jeff
    simul iustus et peccator

  12. #12
    Uranium Lounger viking33's Avatar
    Join Date
    Jun 2002
    Location
    Cape Cod, Massachusetts, USA
    Posts
    6,308
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Some programs not starting on bootup (XP Home SP-2)

    Jeff,
    ----------------------------------------
    Maybe as sometimes happens, the problem will correct itself over time.
    ---------------------------------------
    Sure, sure!
    How about System Restore or even sfc /scannow?
    I don't remember from that other thread, if you had both TI and SR enabled or not.
    BOB
    http://lounge.windowssecrets.com/S/flags/USA.gif http://lounge.windowssecrets.com/S/f...sachusetts.gif


    Long ago, there was a time when men cursed and beat on the ground with sticks. It was called witchcraft.
    Today it is called golf!

  13. #13
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Swanzey, New Hampshire, USA
    Posts
    1,707
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Some programs not starting on bootup (XP Home SP-2)

    I've run "sfc /scannow"... no change. I don't use System Restore. I find using True Image backups more to my liking since everything gets replaced. I looked through "Services" but didn't see anything unusual, e.g., nothing was stopped that would effect this crazy issue. If I get in the right mood, I just might try a Repair Install of XP to see if that would do the trick. Fortunately, this is just a tad more than an annoyance at this point, so I'm not pressed to do something since everything else functions just fine as it always has. <IMG SRC=http://www.the-highway.com/Smileys/crossfingers.gif>

    Jeff
    Jeff
    simul iustus et peccator

  14. #14
    Uranium Lounger viking33's Avatar
    Join Date
    Jun 2002
    Location
    Cape Cod, Massachusetts, USA
    Posts
    6,308
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Some programs not starting on bootup (XP Home SP-2)

    Jeff,
    I think this would be one of the times that I would first try SR before a Repair Reinstall. It's one of the reasons for keeping BOTH SR and True Image active.
    But since you don't have SR enabled then a Repair seems in order. If no joy in that, then a recent Image Restore would be next, IMHO.
    BOB
    http://lounge.windowssecrets.com/S/flags/USA.gif http://lounge.windowssecrets.com/S/f...sachusetts.gif


    Long ago, there was a time when men cursed and beat on the ground with sticks. It was called witchcraft.
    Today it is called golf!

  15. #15
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,592
    Thanks
    5
    Thanked 1,059 Times in 928 Posts

    Re: Some programs not starting on bootup (XP Home SP-2)

    You could try using Sysinternals Freeware - Regmon to see what is changing the registry entries.

    Joe
    Joe

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •