Results 1 to 9 of 9
  1. #1
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Salt Lake City, Utah, USA
    Posts
    9,508
    Thanks
    0
    Thanked 6 Times in 6 Posts

    Taskbar TBs MIA after restart (XP SP2 Media Ed)

    All toolbars in my Taskbar are being unchecked at each Windows shutdown or startup. The TB's are not being deleted, they are just being unchecked so that they do not show after startup til I manually reset them, and the icon display order is being changed ASCII sort order.

    I use the QLTB heavily, and I even recreated it as another folder and added it as a separate Taskbar TB. No matter, any TB I add to the taskbar gets unchecked somewhere in the shutdown or startup process. I uninstalled one recently installed program, and also messed about with iTunes TaskBar and Systray display preferences, as they were the last two things I had changed, but no luck. I tried the registry fix here, but still no luck.

    Any ideas how I can track the cause of and solve this problem?
    -John ... I float in liquid gardens
    UTC -7ąDS

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Taskbar TBs MIA after restart (XP SP2 Media Ed)

    Another thing to check in RegEdit:
    - Navigate to HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVe rsionPoliciesExplorer
    - If there is a value named 'NoSaveSettings', make sure it is set to 0.
    - If there is no such value, there is no need to create it.

    You can also try 'Restore Taskbar to Default Functionality' - # 164, left hand side in Kelly Theriot's Troubleshooting Windows XP, Tweaks and Fixes for Windows XP.

  3. #3
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Salt Lake City, Utah, USA
    Posts
    9,508
    Thanks
    0
    Thanked 6 Times in 6 Posts

    Re: Taskbar TBs MIA after restart (XP SP2 Media Ed)

    Your second suggestion, the VBS script from "Restore TaskBar to Default Functionality", worked. Thanks, Hans.
    -John ... I float in liquid gardens
    UTC -7ąDS

  4. #4
    4 Star Lounger
    Join Date
    Feb 2004
    Location
    Saint Charles, Missouri, USA
    Posts
    565
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Taskbar TBs MIA after restart (XP SP2 Media Ed

    Hans,

    >> "- If there is a value named 'NoSaveSettings', make sure it is set to 0. "
    >> "- If there is no such value, there is no need to create it."

    Based on your second line above, could you not just delete the 'NoSaveSettings' value as well ?
    Scott

  5. #5
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Taskbar TBs MIA after restart (XP SP2 Media Ed

    Probably, but sometimes it's better to be explicit to make a change stick.

  6. #6
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Salt Lake City, Utah, USA
    Posts
    9,508
    Thanks
    0
    Thanked 6 Times in 6 Posts

    Re: Taskbar TBs MIA after restart (XP SP2 Media Ed

    Followup comment. Hans, I was going to write back (well, I am now <img src=/S/anigrin.gif border=0 alt=anigrin width=19 height=19>) and argue with you that

    HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVe rsionPoliciesExplorerNoSaveSettings

    is a BINARY value, not a DWORD, but after running that script, it's back to a DWORD set to zero, so either I looked at the wrong key when I went to edit it, or some program wrote an incorrect value structure to the key. I don't think I looked at the wrong key, for the simple reason that on my next visit to Regedit, the hive hierarchy was open to that correct key.
    -John ... I float in liquid gardens
    UTC -7ąDS

  7. #7
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Taskbar TBs MIA after restart (XP SP2 Media Ed

    Perhaps it became corrupt. It's not common to use a binary value to store a boolean True/False value - usually a DWord or a String value is used.

  8. #8
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Taskbar TBs MIA after restart (XP SP2 Media Ed

    Sorry to be a pain in the you-know-what John, but I don't see where Hans said what type of key it was supposed to be...

  9. #9
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Salt Lake City, Utah, USA
    Posts
    9,508
    Thanks
    0
    Thanked 6 Times in 6 Posts

    Re: Taskbar TBs MIA after restart (XP SP2 Media Ed

    He didn't, but when he said it should be zero, I was expecting a DWORD, not a Binary.

    I don't speak hexawatchamacallit, and the registry is not very familiar territory to me (unlike, say , Gate 14 at the St. Louis Airport Eastern Terminal, where I am as I post this).
    -John ... I float in liquid gardens
    UTC -7ąDS

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •