Results 1 to 3 of 3
  1. #1
    4 Star Lounger
    Join Date
    Jul 2006
    Posts
    531
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Delete query not working (2003)

    For some reason the delete query does not work as it is leaving empty data in the table?
    See attachment, any help would be appreciated.

    What l would like to do is to delete any data in the table but it is not working.

  2. #2
    2 Star Lounger
    Join Date
    Mar 2004
    Location
    Cincinnati, Ohio, USA
    Posts
    102
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Delete query not working (2003)

    See attached.

    SQL = DELETE [tbl AVTS_data].* FROM [tbl AVTS_data];

    You were clearing a field, not deleting a record.

  3. #3
    Super Moderator
    Join Date
    Jun 2002
    Location
    Mt Macedon, Victoria, Australia
    Posts
    3,993
    Thanks
    1
    Thanked 45 Times in 44 Posts

    Re: Delete query not working (2003)

    I agree with the answer you have been given, but I found that your original query did actually work.
    As written it only tries to delete if not null. When I ran it it did that.
    When I removed the criteria it deleted everything.

    Do you realise that with action queries you need to actually execute them. It is not enough to just go the datasheet view.
    To execute the query you need to go to Query Run, or click the Red Exclamation Mark.
    Regards
    John



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •