Results 1 to 7 of 7
  1. #1
    4 Star Lounger
    Join Date
    Dec 2002
    Location
    Kitchener, Ontario, Canada
    Posts
    421
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Report prints blank (2000(SP3))

    Here's a new one for me. I have a report that generates data and shows it fine in print preview, I can export it to Word as an RTF yet when I print it from Access, the pages are completely blank. Other reports in the same database work fine.

    This one's got me completely stumped. Any suggestions where to look?

  2. #2
    Super Moderator
    Join Date
    Jun 2002
    Location
    Mt Macedon, Victoria, Australia
    Posts
    3,993
    Thanks
    1
    Thanked 45 Times in 44 Posts

    Re: Report prints blank (2000(SP3))

    Do you have any code in the OnFormat or OnPrint event of any parts of the report?

    Is the report just bound to a normal query, or are you doing something more complicated?
    Regards
    John



  3. #3
    Gold Lounger
    Join Date
    Jun 2001
    Location
    Crystal Beach, FL, Florida, USA
    Posts
    3,436
    Thanks
    1
    Thanked 34 Times in 34 Posts

    Re: Report prints blank (2000(SP3))

    Even though it is "printing" blank pages, are you getting the same # of blank pages as you see in Print Preview?
    Mark Liquorman
    See my website for Tips & Downloads and for my Liquorman Utilities.

  4. #4
    4 Star Lounger
    Join Date
    Dec 2002
    Location
    Kitchener, Ontario, Canada
    Posts
    421
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Report prints blank (2000(SP3))

    To John: only code that closes the form that inputs a date parameter. This is a very garden variety report with the exception that it has several fields and calculations repeated with different running sums: 1) Over group 2) Over All.

    To Mark: Yes, it prints the right number of pages, but blank. Also, there was a time yesterday when it was taking forever to spool. After I rebooted, it was fine.

    I suppose one of the things I can try is to work on a copy and eliminate certain elements to see if one of them is flaking it out.

  5. #5
    4 Star Lounger
    Join Date
    Dec 2002
    Location
    Kitchener, Ontario, Canada
    Posts
    421
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Report prints blank (2000(SP3))

    I've continued to work on this with no particular success. Access is being very inconsistent with what it likes. I have on a couple of occasions got the report to print only to have it return to blank pages after printing once.
    1) I tried deleting the subreport from the main one which made the main one happy once, then it stopped printing.
    2) I turned the query underlying the subreport into a table to see how the database felt about non-calculated data and it worked once, then stopped.
    3) I have made a new database and imported everything, no difference.
    4) I have run Windows Update, Office Update and checked for recent printer drivers, no change.
    5) I have recreated the subreport, it worked briefly then stopped.

    I have watched the printers dialogue window and it spools then deletes the report. The pages column, interestingly lists N/A rather than the normal page count of 1.

    Other older (and equally or more complex ) reports work just fine. I'm really at a loss for this one. I will take it to a different computer and at least try to determine whether it is my printer that doesn't like something, but it seems a little odd to me to be so incredibly picky about what it won't print. I suppose I can go whole hog and start from scratch with the report.

    Any other suggestions would be most welcome.

  6. #6
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Report prints blank (2000(SP3))

    If you wish, you can post a stripped down copy of your database. See <post#=401925>post 401925</post#> for instructions.

  7. #7
    4 Star Lounger
    Join Date
    Dec 2002
    Location
    Kitchener, Ontario, Canada
    Posts
    421
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Report prints blank (2000(SP3))

    I seem to have it sorted out and the report in question is working on the client's computer, so hopefully it was one of those weird Microsoft moments. What's that old operating system joke that describes Microsoft as this fleet of beautiful jets that work wonderfully and every once in a while they just explode for no reason at all? <img src=/S/blowup.gif border=0 alt=blowup width=60 height=60>

    Regardless, I repaired office, downloaded all of the upgrades I could find for Windows, Office and my printer. Who knows where the problem was!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •