Results 1 to 2 of 2
  1. #1
    4 Star Lounger
    Join Date
    Jan 2003
    Location
    Central Florida, USA
    Posts
    505
    Thanks
    5
    Thanked 0 Times in 0 Posts

    Unable to add records to SQL Server table (Access2k)

    This is a bit strange, at least to me. I have an access FE that links to SQL Server tables BE. I make modifications to the frontend (using Access2003), test it, move it to an Access 2k machine.

    When I open the front end, one table containing three fields will not allow me to add records. I can delete the table, then link to that table via File:Get External Data:Link Tables. I rename the table, eliminating the "dbo_" and it will then allow adding records. ALL other tables allow adding records without deleting them first. I should note that the other tables have primary key fields, and offending table does not have a separate key field, but is identified as unique by Access based on the three fields. The three fields are all numeric, two being foreign keys and the third being a quantity (fkLocation, fkProduct, Qnty).

    This also occurs when I move from one Access 2k machine to another 2k machine, so it does not appear to be related to 03 vs. 2k.

    Has anyone seen this occur before?

    Thanks in advance for any ideas.

    Ken

  2. #2
    4 Star Lounger
    Join Date
    Jan 2003
    Location
    Central Florida, USA
    Posts
    505
    Thanks
    5
    Thanked 0 Times in 0 Posts

    Re: Unable to add records to SQL Server table (Access2k)

    Oops. I think I found the solution. I added a unique index on the SQL Server table and the problem seems to go away. The index was not on the original Access table, but probably should have been.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •