Results 1 to 9 of 9
  1. #1
    Star Lounger
    Join Date
    Jan 2003
    Posts
    58
    Thanks
    0
    Thanked 0 Times in 0 Posts

    IE 7 - Alt-Tab no longer working (IE 7.0 / Win XP Pro SP2)

    I just upgraded to IE 7.0. Now when I try to cycle through my open apps, using Alt-Tab, IE isn't always willing to give up the focus. In other words, when I try to use Alt-Tab to move to another open application, sometimes IE immediately returns to the screen. Sometimes if I try it again at that point it will move over to the other app, but sometimes not. Very irritating. Anyone else had this experience? Many thanks in advance for any suggestions.
    regards,
    Abraham Z.

  2. #2
    Silver Lounger t8ntlikly's Avatar
    Join Date
    Dec 2001
    Location
    Chandler, AZ
    Posts
    2,162
    Thanks
    46
    Thanked 13 Times in 11 Posts

    Re: IE 7 - Alt-Tab no longer working (IE 7.0 / Win XP Pro SP2)

    I havent had any problems with that. Are you using The TaskSwitch Power Toy from Microsoft? Might try re-installing that if you are, or if you arent try installing that.
    Thanks John
    Teamwork is essential; it gives the enemy other people to shoot at. (Murphy's War Laws #39)

  3. #3
    Star Lounger
    Join Date
    Jan 2003
    Posts
    58
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: IE 7 - Alt-Tab no longer working (IE 7.0 / Win

    I did have the TaskSwitch Power Toy installed. I've just tried uninstalling it and so far it appears to have solved the problem. I guess I'll leave it uninstalled now, which I suppose is ok. Just to clarify, you have it installed and no problems with IE 7, right?
    thanks,
    Abraham Z.

  4. #4
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,572
    Thanks
    5
    Thanked 1,057 Times in 926 Posts

    Re: IE 7 - Alt-Tab no longer working (IE 7.0 / Win

    I also has the TaskSwitch Power Toy installed and don't seem to have the problem. I have noticed thought that in spite of using TweakUI to set 'do not steal focus' that IE 7 does not appear to honor that setting when it is rendering pages.

    Joe
    Joe

  5. #5
    Silver Lounger t8ntlikly's Avatar
    Join Date
    Dec 2001
    Location
    Chandler, AZ
    Posts
    2,162
    Thanks
    46
    Thanked 13 Times in 11 Posts

    Re: IE 7 - Alt-Tab no longer working (IE 7.0 / Win

    Yes I had it installed while running IE7 Beta 2 and RC1 as well and no problems
    Thanks John
    Teamwork is essential; it gives the enemy other people to shoot at. (Murphy's War Laws #39)

  6. #6
    Super Moderator
    Join Date
    Dec 2000
    Location
    Renton, Washington, USA
    Posts
    12,560
    Thanks
    0
    Thanked 4 Times in 4 Posts

    Re: IE 7 - Alt-Tab no longer working (IE 7.0 / Win XP Pro SP2)

    Alt-Tab is working just fine for me.

    Now running HP Pavilion a6528p, with Win7 64 Bit OS.

  7. #7
    Star Lounger
    Join Date
    Jan 2003
    Posts
    58
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: IE 7 - Alt-Tab no longer working (IE 7.0 / Win

    I've experimented a bit further and have found that if I uninstall the Alt-Tab Task Switcher powertoy the problem (IE refusing to give up the focus to other apps when I try to cycle to them using Alt-Tab) goes away. In other words, Alt-Tab functionality works fine unless I install the Alt-Tab powertoy, in which case it only works intermittently. There doesn't seem to be much rhyme or reason to when it doesn't work. I have noticed that (with the powertoy installed) if the focus is on IE and I try to Alt-Tab to another app, IE will remain the window in view. If I then Alt-Tab to IE again - so that it has the focus again - and *then* try doing the exact same Alt-Tab to another app again, often it will work on the second try (but only if I first Alt-Tab to IE). I have no reason why any of this would be the case but it seems pretty clear to me that MS probably needs to update the powertoy (or IE 7). In the meantime, I've simply uninstalled the powertoy and that appears to have resolved the problem. (One poster suggested that I tried uninstalling it and reinstalling it - I tried that but the same behavior happened). I don't know if there's any way to report this as a bug to MS but if there is please let me know as it seems pretty plain to me that it is one. Thanks again for all the suggestions.
    Abraham Z.

  8. #8
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: IE 7 - Alt-Tab no longer working (IE 7.0 / Win

    > I don't know if there's any way to report this as a bug to MS but if there is please let me know
    > as it seems pretty plain to me that it is one.

    Not sure you would get a very rapid response on that:
    <hr>Note: We take great care to ensure that PowerToys work as they should, but they are not part of Windows and are not supported by Microsoft. For this reason, Microsoft Technical Support is unable to answer questions about PowerToys.<hr>
    Microsoft PowerToys for Windows XP

  9. #9
    Platinum Lounger
    Join Date
    Nov 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    5,016
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: IE 7 - Alt-Tab no longer working (IE 7.0 / Win

    I have had a similar experience. It might be that having multiple tabs open in a browser window has some effect on it... maybe.

    Alan

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •