Results 1 to 11 of 11
  1. #1
    Star Lounger
    Join Date
    Oct 2006
    Location
    Colorado Springs, Colorado, USA
    Posts
    61
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Disable Outlook shortcut keys (2003)

    I have a customer who wants to disable the CTRL-ENTER shortcut key combo in Outlook. He doesn't want email to be sent when he hits it by mistake. Is there an easy way to do this?

  2. #2
    Star Lounger
    Join Date
    Oct 2006
    Location
    Colorado Springs, Colorado, USA
    Posts
    61
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Disable Outlook shortcut keys (2003)

    Thanks, looks like that's the answer. Do you know how to get the attachment loaded into the registry?

    Never mind. Just did an import, and it works as advertised!

    Thanks to all!

  3. #3
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Salt Lake City, Utah, USA
    Posts
    9,508
    Thanks
    0
    Thanked 6 Times in 6 Posts

    Re: Disable Outlook shortcut keys (2003)

    See Hans and JScher2000's posts <!post=this,548,183>this<!/post> thread. (And ignore my bad joke.)
    -John ... I float in liquid gardens
    UTC -7ąDS

  4. #4
    Star Lounger
    Join Date
    Oct 2006
    Location
    Colorado Springs, Colorado, USA
    Posts
    61
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Disable Outlook shortcut keys (2003)

    This is a great solution if you are using Outlook's built-in email editor, but not if you are using Word to edit emails. Is there a similar fix for Word?

  5. #5
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Disable Outlook shortcut keys (2003)

    In your Word thread you wrote:
    <hr>When editing an email, typing ctrl+enter will immediately send the message. My customer wants to disable that shortcut. The outlook guys pointed me to a registry fix to disable ctrl+enter, and it works perfectly -- IF outlook is being used as the email editor. However, it doesn't work if Word is being used as the email editor. Might there be a similar fix to disable ctrl+enter while editing email in Word?

    As a guess, I tried using the same registry fix, except with a "Word" subdirectory, rather than an "Outlook" subdirectory. It seems to have worked, but also disabled the page break function of ctrl+enter in a normal Word doc. Is this a kosher registry fix? Is there some other way to do it instead?<hr>
    You can create keyboard shortcuts in Word, but where you save them will determine which takes precedence. If you open a message in Outlook and print the key assignments list (use the Print what drop-down), what is assigned to Ctrl+Enter, if anything?

  6. #6
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Disable Outlook shortcut keys (2003)

    > Is there a similar fix for Word?

    Yes: don't use Word as mail editor in Outlook while you still have the chance. <img src=/S/evilgrin.gif border=0 alt=evilgrin width=15 height=15>

    (You won't be able to avoid it in Office 2007)

  7. #7
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Salt Lake City, Utah, USA
    Posts
    9,508
    Thanks
    0
    Thanked 6 Times in 6 Posts

    Re: Disable Outlook shortcut keys (2003)

    Expanding on Jefferson's reply, you could remap the InsertPageBreak command, for example to Alt-Ctrl-Enter, using Tools | Customize | Keyboard | Insert Category | InsertPageBreak; click into the "press new shortcut key box" and enter Alt-Ctrl-Enter. (I don't know my way around Word very well so there may be more to it.)
    -John ... I float in liquid gardens
    UTC -7ąDS

  8. #8
    Star Lounger
    Join Date
    Oct 2006
    Location
    Colorado Springs, Colorado, USA
    Posts
    61
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Disable Outlook shortcut keys (2003)

    On my machine the global key assignments list comes up blank, with or without the registry edit I mentioned ([HKEY_CURRENT_USERSoftwarePoliciesMicrosoftOffice11 .0WordDisabledShortcutKeysCheckBoxes]
    "CtrlEnter"="13,8"). I'm going to assume the customer has the same situation (it did not sound like he has ever done any modifications to keyboard shortcuts).

  9. #9
    Star Lounger
    Join Date
    Oct 2006
    Location
    Colorado Springs, Colorado, USA
    Posts
    61
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Disable Outlook shortcut keys (2003)

    Thanks for the heads-up on where to edit keyboard shortcuts, I'd missed that one. I noticed that if you select "all commands", there is an "EmailSend" command available. Unfortunately, it shows up as unassigned, even though ctl+enter sends mail. I tried assigning ctl+alt+enter to see if it would override, but it doesn't--it sends a message if you press ctl+enter or ctl+alt+enter. But this would work to remap the page break command that gets disabled by the registry entry I mentioned before.

    Thanks again.

  10. #10
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Disable Outlook shortcut keys (2003)

    The key assignments print-out has nothing to do with the registry, and everything to do with the active templates governing the current "document."

    I don't use Word as my mail editor, but I suspect the problem is related to the envelope pane which I have seen appear when choosing File>Send To>Mail Recipient in a regular Word document. As far as I can recall, there is no programmatic way to modify this pane. If the Ctrl+Enter is hardcoded into this feature, then I'm not sure you will find a way to override it. But you can try. Just assign that key combination to do something else and save the change in the most specific template applicable to the message on the screen (perhaps Email.dot will appear in the drop-down?). You can start by using Tools>Customize... and then the Keyboard... button.

  11. #11
    Star Lounger
    Join Date
    Oct 2006
    Location
    Colorado Springs, Colorado, USA
    Posts
    61
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Disable Outlook shortcut keys (2003)

    <P ID="edit" class=small>(Edited by tlebell on 05-Dec-06 11:48. )</P>Ok, I'll give it a try. The aforementioned registry key does disable ctrl+enter in the envelope pane, so that is one way around--it just happens to disable ctrl+enter in a normal word document as well. I guess one must decide which is more important. In the case I'm working on, I doubt he uses ctrl+enter to add page breaks anyway, so the registry fix will be ok. But I'll see about reassigning first.

    Thanks again to everyone for your help!

    -Torry

    PS. just tried setting the "EmailFocusSubject" command to use ctrl+enter, didn't work. Word still sends the message. Guess I'll use the reg key.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •