Results 1 to 7 of 7
  1. #1
    3 Star Lounger
    Join Date
    Aug 2004
    Posts
    361
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Possible Corruption (XP)

    Suddenly of one of my client's Excel files no longer have the excel icon, but that of the flying window. If he opens Excel he can access the files without problem. However if he uses explorer to find files and then attempts to open them, he gets a message, "Windows cannot find 0.exe. This program is needed for opening files of the type 'XLS Files'."

    If he logs on to another machine on the network he still has the flying window icon for excel files. However if he uses explorer and attempts to open the file, it will open directly. That is he does not get the message in the previous paragraph nor does he have to open Excel first.

    Excel runs from the local drive not a network drive, but files are saved on the server.

    Any suggestions?

  2. #2
    Uranium Lounger
    Join Date
    Jan 2001
    Location
    South Carolina, USA
    Posts
    7,295
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Possible Corruption (XP)

    In the windows Start menu select Run. Then enter the following in the Run dialog box:

    "C:Program FilesMicrosoft OfficeOfficeExcel.exe" /Regserver

    Then click on OK. Now, try double clicking on an Execl file.
    Legare Coleman

  3. #3
    3 Star Lounger
    Join Date
    Aug 2004
    Posts
    361
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Possible Corruption (XP)

    Tried "C:Program FilesMicrosoft OfficeOfficeExcel.exe" /Regserver and it cannot find the path. Did a browse to see if I could find the correct path. Found a path to Office 10 folder. Tried changing Office to Office 10, but still no luck in running.

  4. #4
    Uranium Lounger
    Join Date
    Jan 2001
    Location
    South Carolina, USA
    Posts
    7,295
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Possible Corruption (XP)

    OK, then try this:

    1- Start Windows Explorer and find an Excel workbook file.

    2- Right click on the file and in the popup menu select "Open With", then select "Choose Program" in the second popup window.

    3- In the resulting dialog box (it may take a little while for the dialog box to pop up) scroll down until you fine "Microsoft Excel for Windows." Click on it to select it.

    4- In the bottom section of the dialog box, put a check mark next to "Always use this program to open these files."

    5- Click OK.

    You should now be able to double click .xls files again.
    Legare Coleman

  5. #5
    3 Star Lounger
    Join Date
    Aug 2004
    Posts
    361
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Possible Corruption (XP)

    Tried this approach and it still looks for 0.exe when attempting to open through Explorer.

  6. #6
    3 Star Lounger
    Join Date
    Aug 2004
    Posts
    361
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Possible Corruption (XP)

    Ran a Detect and Repair and problem was solved.

  7. #7
    Uranium Lounger
    Join Date
    Jan 2001
    Location
    South Carolina, USA
    Posts
    7,295
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Possible Corruption (XP)

    Then my only suggestion is to go back to my first post in this thread and figure out how to make that work. When you tried it, did you put the quotes around path and program name? They have to be there. What you are trying to do is run Excel.exe with a parameter of /regserver on the command line.
    Legare Coleman

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •