Results 1 to 9 of 9
  1. #1
    3 Star Lounger
    Join Date
    Nov 2001
    Location
    Costa Rica
    Posts
    235
    Thanks
    12
    Thanked 0 Times in 0 Posts

    AutoCorrect entries disappear (Win XP SP2 Ofc 2003)

    Dear Sirs,
    I keep having to enter AutoCorrect words over and over again. I am using 3 languages, English, Spanish and Sanskrit. Somehow, Danish got added to the list - I don't know how or how to fix that.
    The biggest problem, though, is that I have entered many Sanskrit words and when I save the version of the song book I am creating, many times, the words have to be entered all over again. I am entering numbered songs, either in Spanish or Sanskrit with Spanish translations.
    Anybody know what to do with this problem?
    I have other difficulties with this book, but I am going to post the problems separately, so that a search will allow other people to find them.
    Thank you,
    Julia

  2. #2
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: AutoCorrect entries disappear (Win XP SP2 Ofc

    I don't have any personal experience with multilingual AutoCorrect entries. However, I do know that Word maintains distinct .acl files by language (or LCID, like 1033 for English). How would Word know which file your Sanskrit entry should go into? Hmmm... I can imagine two possibilities. One is, if you have intentionally coded the text with Tools>Language>Set Language before adding it, Word might save it in the Sanskrit .acl, assuming there is one. Otherwise, Word might view it as a formatted "English" AutoCorrect entry and save it in Normal.dot. If Word is doing the latter, then losing those entries might be a result of an add-in that interferes with saving changes to Normal.dot. Some versions of Adobe's PDFMaker toolbar will do this. To "force" a save of Normal.dot, hold Shift and click File; the Save entry should change to Save All.

  3. #3
    3 Star Lounger
    Join Date
    Nov 2001
    Location
    Costa Rica
    Posts
    235
    Thanks
    12
    Thanked 0 Times in 0 Posts

    Re: AutoCorrect entries disappear (Win XP SP2 Ofc

    Hi, jscher!
    Thanks for the response!
    Let's see now - Language is set to detect automatically, and I have wondered myself, if it was saving into a different language. I am switching from moment to moment into 1 of 3 languages, since the song book is for groups who sing in all 3 languages. So, for instance, I will type a Sanskrit language song, give the Spanish translation, or give the Spanish translation for an English song (this particular book is primarily to allow Spanish-speaking people to understand what they are singing).
    I notice that the automatic detection doesn't always work. I might be typing in Sanskrit, and the language will show Spanish or even Danish, although I have no idea where that came from.
    I am, now, following every entry into AutoCorrect with a File>Save All, in hopes of maintaining the words when I rename the file as a 'Save As', to ensure that I don't lose too much in case of drastic whatever. I never could find whether the AutoCorrect is different for different languages. I tried to find my AutoCorrects in the dictionaries, but they don't appear - that only has the entries I have 'Add(ed) to Dictionary'.
    How does one access the '.acl'? Is it possible to place all the AutoCorrect in one place so that it is accessed by every language? I should think that is the way it should be, but...
    I just went into the latest file. Yes, the AutoCorrect is putting different entries into different languages. It doesn't matter if I turn off the 'detect language automatically' - it switches the language anyway. The Sanskrit entries are showing English. And I'm not sure how that works, either I just went in and selected Sanskrit as the language, in the middle of a Sanskrit song. The AutoCorrect and the bar at the bottom still shows English as the language.
    If the language keeps changing from minute to minute, I guess I have to 'Set Language' every time I want to AutoCorrect. But that means that if I am typing something all in English with a few Sanskrit words, those words are not available to me.
    Well, I'm not sure what can make this work better for me, but I am doing the Shift>File>Save All every time I make an entry now, so I see that my previous document's entries are there (not that I remember ech of them - there are so many) There are a lot of entries, because I am writing the Sanskrit songs with accents given by a Sanskrit/Spanish translator in Venezuela - the accents are intended to help Spanish people pronounce the words easier.
    Let's see now - about the Adobe's PDFMaker toolbar: I took that toolbar off the toolbars viewed, because I just never use it. I have the full version of Adobe Acrobat 7, latest update. Should I contact Adobe to see if there is a known bug, and if so, how would I state my question?
    Thanks for being there, and I wish you and your a Happy Holiday season and a wonderful new year.
    Julia

  4. #4
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: AutoCorrect entries disappear (Win XP SP2 Ofc

    Julia, are you a speed typist? That's a lot of information. <img src=/S/grin.gif border=0 alt=grin width=15 height=15>

    As I said, I don't know how multilingual .acl files work. You could check whether the .acl files themselves have been updated recently. The computer I'm using at the moment doesn't have Office installed, but if you search for *.acl in Windows Explorer, you can locate the files on your computer and see which ones have been updated recently.

    There is a tool to back up your AutoCorrect entries. The one for Word 2002 is here: How to move AutoCorrect entries between computers in Word 2002 (MSKB 269006).

    Regarding PDFMaker, there is a difference between hiding a toolbar and uninstalling an add-in or global template. If you open Tool>Templates and Add-ins, is there a PDF template listed? If so, to remove it temporarily, you can move it out of the Word Startup folder (Word needs to be closed in order to do this). Step-by-step directions have been posted in past threads.

  5. #5
    3 Star Lounger
    Join Date
    Nov 2001
    Location
    Costa Rica
    Posts
    235
    Thanks
    12
    Thanked 0 Times in 0 Posts

    Re: AutoCorrect entries disappear (Win XP SP2 Ofc

    Hi, jscher!
    I did the search you recommended, and discovered 4 different .acl files have been updated. Obviously, some of my AutoCorrect entries are in one file, and others are in the others. I can tell my backup to select the .acl files for backup, which would allow me to retrieve them - that would really help, I think.
    But it looks to me as though I am going to have to set the language before making any entries, to ensure it goes into the same one - too bad - I need them in both English and Spanish. Most of them must be sitting in that Danish language. I know I should be able to eliminate languages, but I didn't see any way to do that going into Settings>Control Panel>Regional and Languages. Since it never selects Sanskrit, even when it is sitting in that language, I would get rid of that as well. That process should help eliminate the words going into the 3rd and 4th languages.
    Do you happen to know how to keep it from automatically going into a language, by any chance?
    I looked in my Word under Tools>Templates and Add-ins. The only thing is 'Normal' at the top, and nothing is listed under 'Global Templates and Add-ins'. That should be good, then, right?
    I appreciate you taking the time to help me, jscher!
    Julia

  6. #6
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: AutoCorrect entries disappear (Win XP SP2 Ofc

    Julia, I'm hoping some of the European users can assist you with the language selection issues.

  7. #7
    3 Star Lounger
    Join Date
    Nov 2001
    Location
    Costa Rica
    Posts
    235
    Thanks
    12
    Thanked 0 Times in 0 Posts

    Re: AutoCorrect entries disappear (Win XP SP2 Ofc

    Hi, jscher!
    Thanks for responding again!
    Yes, I think you are right to suggest that I wait until somebody who works with these things all the time to help me.
    Meanwhile, I will try to remember to select Spanish before I enter any AutoCorrect entries, so at least they are all in one place! (After I forget 5 or 6 times, I'm sure I'll remember!)
    Thanks,
    Julia

  8. #8
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts

    Re: AutoCorrect entries disappear (Win XP SP2 Ofc 2003)

    Julia,

    My advice for managing the Autocorrect entries in this document is to
    <UL><LI>Disable automatic language detection
    <LI>Set all the text in the entire songbook to a single language[/list]you can do this by

    <UL><LI>Edit > Select All
    <LI>Tools > Language
    <UL><LI>Clear the "Detect language automatically check box
    <LI>Select a language from the list (maybe Spanish would be best)[/list]<LI>Click OK[/list]StuartR

  9. #9
    3 Star Lounger
    Join Date
    Nov 2001
    Location
    Costa Rica
    Posts
    235
    Thanks
    12
    Thanked 0 Times in 0 Posts

    Re: AutoCorrect entries disappear (Win XP SP2 Ofc 2003)

    Okay, that sounds good. I will do that, although what I have seen before, is that even though I had turned off the 'detect language automatically', it still showed different languages in the status bar. But then, I hadn't selected the entire file first - that probably will make the difference.
    Thanks again!
    Julia

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •