Results 1 to 9 of 9
  1. #1
    Star Lounger
    Join Date
    Jan 2001
    Location
    Chantilly, VA USA
    Posts
    54
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Acrobat Behaving Erratically (Acrobat 7.0)

    I'm having a problem with Acrobat 7.0 behaving erratically in Access. (This may in fact be an Acrobat configuration problem, but I'm not sure where else to post this. If it belongs on another board please transfer)

    I have a database from which I run a series of Reports. I print these Reports in PDF format. The Reports include different colored fonts.

    Sometimes, when I print by launching Acrobat by clicking on the Acrobat icon in the Acrobat Tool Bar, a Report prints entirely in Black-and-White. Other times, it prints with the proper colors.

    If I print by launching Acrobat from Access' File > Print menu, the Reports always print in the proper colors.

    I don't run into this problem with any other Office apps, just Access.

    Any ideas on what's going on here?

    Thanks,

    Don Brownlee

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Acrobat Behaving Erratically (Acrobat 7.0)

    I can't find anything about this, so I can only suggest that you print to the Acrobat printer instead of using the toolbar button. Sorry.

  3. #3
    Platinum Lounger
    Join Date
    Dec 2001
    Location
    Melbourne, Australia
    Posts
    4,594
    Thanks
    0
    Thanked 27 Times in 27 Posts

    Re: Acrobat Behaving Erratically (Acrobat 7.0)

    Dont know if it applies to you here, but i have found when outputting to a .pdf file and trying to email it, that it had not finished writing it out to disk when i tried to email. This resulted in a acrobat error.

  4. #4
    Star Lounger
    Join Date
    Apr 2006
    Location
    California
    Posts
    69
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Acrobat Behaving Erratically (Acrobat 7.0)

    Don,

    I'm having a similar problem. In my situation the problem is with any report that has a photo in it. If I use print preview and print the report with photo from preview it will come out OK. If print straight to the printer it always comes out in b&w. In addition, if I go back to print preview, it too will now print in b&w.

    I was using Acrobat 5.0 and have just upgraded to 8.0. This didn't help, still have the problem. I've also tested it on several computers with different versions of windows. I get the same results. I've also tested it under Access 2002 and 2003 ... again same results.

    I'm at a loss as to what to try next.
    Marty

  5. #5
    4 Star Lounger
    Join Date
    Dec 2002
    Location
    Kitchener, Ontario, Canada
    Posts
    421
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Acrobat Behaving Erratically (Acrobat 7.0)

    Would it be possible in your situation to actually save the report to a named pdf file and then print it? It could always have the same name and just be constantly overwritten. I use Stephen Leban's free Report to PDF in an application that churns out sales statements for a consignment art gallery. It creates the pdf, attaches it to an email, sends it and then starts all over again. Because each statement has the same name, you aren't left with piles of documents. Just the last one to be printed. You have the option of opening the pdf or not.

    Access 2007 apparently has built in support for pdf but I haven't been thrilled with it in the one situation where I have no choice.

  6. #6
    Star Lounger
    Join Date
    Apr 2006
    Location
    California
    Posts
    69
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Acrobat Behaving Erratically (Acrobat 7.0)

    Peter,

    I'm currently saving the pdf reports. I've tried resuing the same name as well as creating a new name. I've also tested a couple of pdf printer drivers other than Adobe, always getting the same outcome. As there doesn't seem to be much reported on this problem I have a feeling it must be some setting I'm not managing well in the reports. But I can't get a handle on what's different in how Access prints a report using acNormal vs acPreview->Print.

  7. #7
    4 Star Lounger
    Join Date
    Dec 2002
    Location
    Kitchener, Ontario, Canada
    Posts
    421
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Acrobat Behaving Erratically (Acrobat 7.0)

    If you are saving the pdfs, you should be printing them from acrobat. Your report view - acNormal or acPreview - shouldn't have anything to do with the pdfs at that point. The process should be as follows: 1) open the report in Access in Preview (so Access doesn't send it to the printer) 2) output it to pdf format 3) print the pdf.

    If you are using Normal, it gets sent directly to the printer, which means you aren't really printing the pdf at all (at least as I understand it. Someone clever like Hans can correct me if I am wrong)

    #3 should be doable from VBA. If you use something like Leban's utility you have the option, once the document is created to open or not open Acrobat. It depends what you need to accomplish and whether you want it all to happen in code or you are happy doing some of it manually. I put the code for Report to PDF into the report's OnActivate event.

  8. #8
    Star Lounger
    Join Date
    Apr 2006
    Location
    California
    Posts
    69
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Acrobat Behaving Erratically (Acrobat 7.0)

    Peter,
    I'm printing to a pdf "converter" printer (I've tested Acrobat PDFWriter 5.0, Adobe PDF 8.0 and docuPrinter). Adobe PDF 8.0 and docuPrinter are my prime choices as they allow me to merge multiple reports/pdfs into one pdf file. For Adobe PDF 8.0, I simply make it the active/default printer and run a series of DoCmd.OpenReport stDocName, acNormal for each report to be printed/generated. As I've stated before, with the acNormal option the generated pdfs are in b/w. If I change the syntax to acPreview and restart Access, the pdfs for reports with photos will be in color. I can print repeatedly and the pdfs are always in color with acPreview. If I change the syntax back to acNormal, the pdfs for reports with photos are in b/w.

    Marty

  9. #9
    4 Star Lounger
    Join Date
    Dec 2002
    Location
    Kitchener, Ontario, Canada
    Posts
    421
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Acrobat Behaving Erratically (Acrobat 7.0)

    Haven't got a clue! <img src=/S/scratch.gif border=0 alt=scratch width=25 height=29>

    All I can suggest, is consider trying Report to PDF as it is not actually using a printer converter to create the file. Might work, might have the same problem. Sorry. ReportToPDF

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •