Results 1 to 7 of 7
  1. #1
    5 Star Lounger
    Join Date
    Jul 2003
    Location
    USA
    Posts
    728
    Thanks
    7
    Thanked 2 Times in 2 Posts

    Macros -able/disable (2002/SR2)

    Hi -

    Have a document that suddenly causes the document contains Macros, Able/Disable wndow to appear. I have used File/Insert and saving the document as RTF then back to Word, but the wndow still appears.

    It's an annoyance to have to click Enable whenever I open the file.

    I have scanned the file and there are no viruses in it. Any ideas? (I do copy/paste from the Web to that file, but both virus scanners I used said there were no viruses in the file...)

    Thank you much,
    ACER

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Macros -able/disable (2002/SR2)

    Try the following:
    - Select the entire document without the final paragraph mark (for example by pressing Ctrl+A then Shift+left arrow).
    - Copy to the clipboard (Ctrl+C)
    - Create a blank new document (Ctrl+N)
    - Paste the contents of the other document (Ctrl+V)
    - Save the new document (Ctrl+S)
    Hopefully the new document doesn't display the macro warning.

  3. #3
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Macros -able/disable (2002/SR2)

    <P ID="edit" class=small>(Edited by jscher2000 on 12-Jan-07 14:52. )</P>In some versions of Word, I think that buttons or other (ActiveX) controls from the Control Toolbox could cause that warning. However, not being one who uses that feature, I unfortunately can't recall the details. Also I'm not sure they would have survived the conversion to RTF. (Note that you need to close the document after saving to RTF and then re-open it from disk to make sure Word is not retaining Word features in memory.)

    Additional Thought: Press Alt+F9 and look for field codes that Word might have carried over from the browser. Linked images (INCLUDEPICTURE) can be converted to pictures or whatever by unlinking them from their source (Ctrl+Shift+F9). What I'm curious about is whether there might be any scripts or interactive content that is triggering the warning.

  4. #4
    5 Star Lounger
    Join Date
    Jul 2003
    Location
    USA
    Posts
    728
    Thanks
    7
    Thanked 2 Times in 2 Posts

    Re: Macros -able/disable (2002/SR2)

    Thanks, Hans.

    I had tried your method and still got the warning. I even tried to save the file with a new name. Got the warning.

    If I choose the disable macros button, would I be losing anything?

    Thank you, Acer

  5. #5
    5 Star Lounger
    Join Date
    Jul 2003
    Location
    USA
    Posts
    728
    Thanks
    7
    Thanked 2 Times in 2 Posts

    Re: Macros -able/disable (2002/SR2)

    <P ID="edit" class=small>(Edited by acerfmayer on 12-Jan-07 18:19. Oops. Spoke too soon. There were IncludePicture codes in the doc. I deleted them and all is well.

    Thanks so much,

    Acer
    )</P>Evening, Jefferson -

    Yes, I did close the doc after savng to RTF and then re-opened it.

    I pressed Alt+F and nothing happened, so I'm presuming that no field codes were found.....

    Appreciate your input.

  6. #6
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Macros -able/disable (2002/SR2)

    By the way, I noticed that the "browse by" menu at the bottom of the vertical scroll bar lets you browse by field codes (indicated with {a}) so that might be another way to inspect future documents where you've pasted stuff from IE.

  7. #7
    5 Star Lounger
    Join Date
    Jul 2003
    Location
    USA
    Posts
    728
    Thanks
    7
    Thanked 2 Times in 2 Posts

    Re: Macros -able/disable (2002/SR2)

    Thanks for that tip. I do forget to use that Browse button....

    Acer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •