Results 1 to 8 of 8
  1. #1
    4 Star Lounger
    Join Date
    Feb 2001
    Location
    Richland, Washington, USA
    Posts
    407
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Outlook Form Doesn't Open (2003 SP2)

    I submitted this question a month or so ago, but didn't get an answer (of course, maybe there isn't one). Just in case you didn't see the previous post, but know what's going on here (and how to fix it!)...

    About 18 months ago I created an Outlook Form (.oft file) for users to fill out a questionnaire. It had a hidden "To" field so that when they completed the questionnaire and hit the Send button, it would go to the person who was going to compile the results. Everything worked fine back then.

    We went to use this form again yesterday and when the .oft file is opened (it's a hyperlink in a PowerPoint presentation) all they get is a blank e-mail (normal format) pre-addressed to the person it's supposed to go to. They don't get the custom form (the questionnaire). One other piece of evidence: I tried this myself and got the same behavior. I went into Outlook and opened this form template in design mode and then saved it. From that point on, it opened correctly for me. However, the other user (several have tried it) still get the blank e-mail when they open the file (either from PowerPoint or by double-clicking on it in the the file directory). The .oft file is on a network shared area; we're all trying to open the same file -- it now works for me, but still doesn't work for others.

    Any ideas? Is there some switch buried in Outlook that needs to be turned on to enable Outlook custom forms (e.g., it used to be on by default so everything work fine before, but now is off by default as a result of some Office patch and I turned it back on for me by virtue of editing the form)?

    Thanks.

  2. #2
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Outlook Form Doesn't Open (2003 SP2)

    Do you use Exchange Server? For security reasons, it is best to publish the form (not the template based on the form) to a shared forms library.

  3. #3
    Star Lounger
    Join Date
    Oct 2003
    Location
    Vancouver, Washington, USA
    Posts
    88
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Outlook Form Doesn't Open (2003 SP2)

    We are getting the same results -- using Exchange server 2003 and Outlook cache Exchange mode. How to publish to the forms library.

  4. #4
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Outlook Form Doesn't Open (2003 SP2)

    After editing the form, use Tools>Forms>Publish (sorry, don't have the menus in front of me) to publish the form to the desired library or public folder. Usually only the user's own library/folders are available unless the administrator provides additional privileges.

  5. #5
    Star Lounger
    Join Date
    Oct 2003
    Location
    Vancouver, Washington, USA
    Posts
    88
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Outlook Form Doesn't Open (2003 SP2)

    Your suggestion works. Thanks.
    The only way that we know to open the published form is to go to Tools>Forms>Choose Form and then select the location of the form and open it. Is there a way to make a shortcut directly to the published form? Does not matter if the shortcut is on the desktop or in Outlook. Our endusers would find a shortcut vastly easier to use.

  6. #6
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Outlook Form Doesn't Open (2003 SP2)

    I wish I knew the answers, but I work with forms as infrequently as possible. We've published our shared forms to Public Folders, which also involve navigation hassles (they appear at the bottom of the Actions menu only when in the right folder).

    You might try the Slipstick site or other Exchange resources for more tips on forms.

  7. #7
    Star Lounger
    Join Date
    Oct 2003
    Location
    Vancouver, Washington, USA
    Posts
    88
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Outlook Form Doesn't Open (2003 SP2)

    Thanks. Did not know about that site. It looks grreat.

  8. #8
    4 Star Lounger
    Join Date
    Feb 2001
    Location
    Richland, Washington, USA
    Posts
    407
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Outlook Form Doesn't Open (2003 SP2)

    The saga continues...

    I've tried publishing this form to a Public Folder. When I navigate to the folder, the form indeed appears at the bottom of the Actions menu (a "curious" arrangement) as advertised. The form opens fine for me. However, one of my colleagues does exactly the same thing (I watched him do it) -- he gets to the public folder and highlights it, but the form does not appear in his Actions menu.

    Is there some switch in Outlook that needs to be turned on to permit form use? Or is there a setting in the form itself (that I haven't found yet) that permits "public" access? Or something else?

    Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •