Results 1 to 4 of 4
  1. #1
    Lounger
    Join Date
    Dec 2004
    Posts
    25
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Mapped Network Drive causes system hang offline (XP Pro SP2)

    I have two laptops and a PC - My new laptop is an IBM Thinkpad T60 running XP Pro with SP2 as is my PC (IBM ThinkCentre running XP Pro SP2) and I have recently reformatted my old laptop (Acer Aspire 2001) and reimaged the machine which contains XP Home SP2. All updates have been applied to all machines so they are all current.

    The problem I am having is with Mapped Netowrk Drives.

    Tha first issue is with the Acer Aspire - When at home, I have connected the two via a crossover cable and assigned Alternate IP Addresses as follows:

    Acer Aspire - 192.168.100.99
    Thinkpad T60 - 192.168.100.98
    Both have a gateway of 192.168.100.100.

    I have then added an entry into my hosts file on the Thinkpad T60 as follows:

    192.168.100.99 SW-ACER-NTBK

    I have then accessed the Acer from Start > Run using:

    SW-ACER-NTBK

    On the AcerI have shared the "SharedDocs" folder for unrestricted access and then Mapped the drive to the Thinkpad T60 as Drive M:

    e.g.

    M: (SW-ACER-NTBKSharedDocs)

    This works fine and I have then Made a number of files "Offline" so that I can access them remotely when needed.

    When I am connected to the Acer, everything works fine, I can access files quickly and without issue at teh drop of a hat. I can do that same when I disconnect the cable by accessing the offline versions of the file. The problem comes after reboot - If I am not connected to the Acer and I try to access the M: drive for anything, explorer on the T60 simply locks up and hangs for over 1 minute...After that minute the Offline files icon appears in the taskbar with the standard bubble - "You are now working offline...." and I can freely and easily access the M: quickly and easily as much as I like until I reboot again and the same problem re-occurs.

    I've tried commenting out the host file entry thinking that maybe it is spending to long trying to find 192.168.100.99 and hoping that if it can't resolve SW-ACER-NTBK it will return quicker but this is not the case.

    When I have used offline files and a mapped network drive with the PC (fromthe Acer) it has always been instant with no delay at all (perhaps 1-2 seconds but nothing of concern) - It has only started happening since I got the T60. I have mapped the PC to my N: (SW-IBM-PCHDD) but have not initiated offline files on this machine.

    The properties of the M: drive (SW-ACER-NTK) when disconnected is:

    File System: *NT5CSC

    The properties of the N: drive (SW-IBM-PC) when disconnected is:

    File System: NTFS

    What is it that is taking so long? Has anyone experienced this type of delay before?

    Any assistance would be appreciated.

    Thanks

    Shanon

  2. #2
    Lounger
    Join Date
    Dec 2004
    Posts
    25
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Mapped Network Drive causes system hang offline (XP Pro SP2)

    This issue has now been resolved. Previously the hostname I was using for the Acer Laptop was ACER-ASPIRE. When I tried to access the drive and I wasn't connected, it started looking for 192.168.100.99 which leading out to the internet somewhere. I tried commenting the entry out but it turns out it was resolving ACER-ASPIRE to another address that resided on the Internet.

    I changed my hostname to SW-ACER-NTBK in an effort to select something a little more unique but I didn't test all scenarios properly... It turns out, if I comment the hosts file entry out and reboot, the machine instantly realises that it can't resolve SW-ACER-NTBK and immediately shows me the folders I want to see...

    Problem solved.

  3. #3
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Mapped Network Drive causes system hang offline (XP Pro SP2)

    Thanks for sharing the solution.

  4. #4
    Lounger
    Join Date
    Dec 2004
    Posts
    25
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Mapped Network Drive causes system hang offline (XP Pro SP2)

    It turns out that it was a little more in depth than that.
    In the TCP/IP settings of my LAN connection, under "Advanced" > "DNS" is a check box labelled "Register this connection's addresses in DNS"
    As the SW-ACER-NTBK connection was registered as a local IP address at home, when i got to the office it was registered in the AD DNS.
    We cleared the AD DNS and unchecked this box and all is resolved.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •