Results 1 to 4 of 4
  1. #1
    2 Star Lounger
    Join Date
    Mar 2001
    Posts
    165
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Macros disabled (2002 SP3)

    I have my business records for 2006 in an Excel file. I wrote two macros for inserting and deleting rows. I certified the macros using selfcert.exe. They worked fine last year. Now somehow every time I open the file I get this error message: "Macros in this workbook are disabled because the security level is high, and the macros have not been digitally signed or verified as safe. To run the macros, you can either have them signed or change your security level. Click help for information." As I said, the macros worked fine up until recently. I have another Excel file for my 2007 records with the same macros and I don't get any warnings when I open that file. Short of lowering my security level, how do I get back to where I can use these macros?

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Macros disabled (2002 SP3)

    Try the following:

    - Removing the digital certificate from the workbook.
    - Close and save the workbook.
    - Reopen it, then sign the code again.
    - Close and save the workbook.

  3. #3
    2 Star Lounger
    Join Date
    Mar 2001
    Posts
    165
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Macros disabled (2002 SP3)

    How do I remove the digital signature from the workbook?

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Macros disabled (2002 SP3)

    More or less the same way you added it: in Tools | Digital Signature in the Visual Basic Editor.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •