Results 1 to 11 of 11
  1. #1
    4 Star Lounger
    Join Date
    Feb 2006
    Location
    Cape Cod, Massachusetts, USA
    Posts
    408
    Thanks
    0
    Thanked 0 Times in 0 Posts

    msconfig error message (XP sp2)

    I have a new minor problem. If I open the System Configuration Utility, go to the startup tab, uncheck an item (any item) from running at startup and then press either Apply or Ok , I get the error message shown below. The interesting thing is that in spite of the complaint by the system it makes the change requested.

    The only related change I made some time back was to change my password. I am logged in as the computer administrator and that id is password protected. Looking at User Accounts verifies that.
    So, what is the likely cause of this new message and how can I correct it?
    Paul
    Attached Images Attached Images

  2. #2
    Silver Lounger
    Join Date
    Apr 2001
    Location
    New York, New York, USA
    Posts
    2,328
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: msconfig error message (XP sp2)

    Try to type following in the Run box:

    runas /user:administrator %windir%pchealthhelpctrbinariesmsconfig.exe

    You may be prompted to type Administrator password (no typed password characters will be seen!).

  3. #3
    4 Star Lounger
    Join Date
    Feb 2006
    Location
    Cape Cod, Massachusetts, USA
    Posts
    408
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: msconfig error message (XP sp2)

    I did what you suggested and got the following results:
    After copying & pasting your runas command in the Run window, the DOS window appeared and asked for the password. I typed it in, the DOS window went away and the MSCONFIG window appeared. I unchecked a box, clicked OK and got the same error message. In other words, the behavior was the same as before.

    I then restarted the system, opened the Run command box, typed in MSCONFIG and got the original behavior with the error message.
    I next tried your runas command again. This time, and in all subsequent tries, the dos window disappears after typing in the password and nothing happens, that is, no msconfig window appears.
    Don't know what that implies yet.

    I do not know if the following is relevant information, but I tried running the Sysinternals autostart program viewer (autoruns.exe) . It, by the way lets me deselect items from running with no complaint. When I click on User , it lists three users separately: my login name, Administrator & Guest .

    Paul

  4. #4
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,592
    Thanks
    5
    Thanked 1,059 Times in 928 Posts

    Re: msconfig error message (XP sp2)

    From Autoruns help: "On Windows NT/XP/2000/2003 systems that have multiple user accounts the Users menu is populated with user names. Select one to view the auto-starting images for that account."

    Have you tried running Regedit and checking the permissions settings for the keys in question? Go to HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentV ersionRun. right click and select permissions. Same for HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVe rsionRun.

    Joe
    Joe

  5. #5
    Silver Lounger
    Join Date
    Apr 2001
    Location
    New York, New York, USA
    Posts
    2,328
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: msconfig error message (XP sp2)

    Do you run any third-party firewall program which prevents an access to system files on your computer?

  6. #6
    4 Star Lounger
    Join Date
    Feb 2006
    Location
    Cape Cod, Massachusetts, USA
    Posts
    408
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: msconfig error message (XP sp2)

    Joe,
    You may have identified the problem. The current_user Run key permissions for both my login and Administrators have the Allow check boxes for "full control" and "read" grayed out (see below). A similar story for the local_machine Run permissions. Guess I am going to have to read up on managing users and see how to deal with this. The funny thing is that the problem cited in this thread is new.

    Paul
    Attached Images Attached Images

  7. #7
    4 Star Lounger
    Join Date
    Feb 2006
    Location
    Cape Cod, Massachusetts, USA
    Posts
    408
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: msconfig error message (XP sp2)

    Negative on third party firewall. I use the XP Pro firewall (and the nat in my wireless router)

    Paul

  8. #8
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,592
    Thanks
    5
    Thanked 1,059 Times in 928 Posts

    Re: msconfig error message (XP sp2)

    Greyed out = inherited from a higher level. Were you trying to disable a service also? If you you need to check permissions for the service under HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServices.

    Joe
    Joe

  9. #9
    4 Star Lounger
    Join Date
    Feb 2006
    Location
    Cape Cod, Massachusetts, USA
    Posts
    408
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: msconfig error message (XP sp2)

    Yes Joe, when this error message first appeared I was trying to disable a service. The service key permissions have the Administrator Allow boxes greyed out, the Creator Owner Allow boxes active, but unchecked. (Power Users and Users also have unchecked active boxes boxes).

    Paul

  10. #10
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,592
    Thanks
    5
    Thanked 1,059 Times in 928 Posts

    Re: msconfig error message (XP sp2)

    Were you looking at the service you tried to disable or the higher level key I posted? BTW, you could always try the advanced 'button' and see what that exposes.

    Joe
    Joe

  11. #11
    4 Star Lounger
    Join Date
    Feb 2006
    Location
    Cape Cod, Massachusetts, USA
    Posts
    408
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: msconfig error message (XP sp2)

    I was looking at the higher level key. When I look at specific services I get similar information. The advanced button does offer more control than I know what to do with comfortably at the moment. I think a little bit of study on my part is appropriate before making changes.

    This issue is simply an annoyance not a hindrance. When I try and stop a service the error message appears, but it does stop the service. It's as if the first level of security is unhappy, but the next level is OK.

    Paul

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •