Results 1 to 5 of 5
  1. #1
    New Lounger
    Join Date
    Sep 2006
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Error opening db on Terminal Services (A2000)

    Subject edited by HansV to be slightly more descriptive than "Access 2000"

    Good afternoon/morning/evening all -

    We have a non admin user that is connecting to us via Terminal Services and when this user attempts to double click on an existing Access database (or any Access database for that matter), they receive a Windows Installer box, that disappears, and then they receive an error with the following syntax:

    This file does not have a program associated with it for performing this action. Create an association in the Folder Options control panel.

    However, if this same user clicks on StartProgramsAccess 2000, they can run any and all Access databases on the server.

    This problem appears to be unique to this user since we can log on via Terminal Services to the same server as any other non admin user and this problem does not exist.

    Microsoft's KB did not help us out, so I figured I would turn to the experts.

    Any help would be appreciated and thank you in advance.

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Error opening db on Terminal Services (A2000)

    As a first step, let the user make sure that "Ignore DDE Requests" is off (clear) in the Advanced tab of Tools | Options in Access.

    If that doesn't apply, let the user right-click an .mdb file in Windows Explorer.
    Select Open with | Choose Program... from the popup menu.
    Select Microsoft Access in the list of programs (click Browse... if it isn't listed), and make sure that "Always use the selected program to open this kind of file" is on (ticked).
    Click OK.

  3. #3
    New Lounger
    Join Date
    Sep 2006
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Error opening db on Terminal Services (A2000)

    I confirmed that Ignore DDE Requests was off on the ToolsOptionsAdvanced tab. I then tried to associate MS Access with .mdb files via Windows Explorer as suggested, however, and I'm guessing it's due to the non admin factor of this user, the Always use this program to open these files option is grayed out. Even still, I clicked Microsoft Access for Windows in the 'Open With' section, and receive the same error, which contains the following syntax:

    This file does not have a program associated with it for performing this action. Create an association in the Folder Options control panel.

    Thanks for the attempt - any other suggestions?

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Error opening db on Terminal Services (A2000)

    Try logging in with an Admin account on that PC to set the association.

  5. #5
    New Lounger
    Join Date
    Sep 2006
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Error opening db on Terminal Services (A2000)

    Logging on as Administrator did not help (also, this issue is residing on a server running Windows 2000 server).

    However, I did find a resolution.

    I logged on the server as Administrator, went into Terminal Services Configuration, accessed the Properties on the connection, gave the problem user login Full Control under the Permissions tab. I logged out of the server as Administrator and logged back in as the problem user.

    I then double clicked on an Access 2000 database, and a message popped up that the Windows Installer was accessing the MS Office 2000 disc 2. After this errored out with a 1706 error, I clicked OK, and then received the 'file not associated' error again. I clicked OK on this error and then I was let into the Access 2000 database.

    To confirm this still worked, I logged out as the problem user, and then logged back in as Administrator. I removed the problem user from the connection Permissions tab, logged off as Administrator, logged back on as the problem user, and everything works fine now.

    Thank you for the assistance Hans and keep up the good work.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •