Results 1 to 5 of 5
  1. #1
    3 Star Lounger
    Join Date
    Mar 2006
    Location
    Pittsburgh, Pennsylvania, USA
    Posts
    289
    Thanks
    0
    Thanked 1 Time in 1 Post

    Sending Email (2003 sp2)

    I was always under the impression that you could only send email from Access using Outlook until I read one of the posts here and discovered otherwise. This would be invaluable to me so I began to test immediately using the following code:
    DoCmd.SendObject acSendReport, "rpt_NEW_REVIEW_FORM", acFormatSNP, _
    "charles.rau@pnc.com ", , , "Test", _
    "I am testing sending email from access", False

    However, this does not send the email but opens it populated with the coded instructions, which is wonderful, but how do I bypass opening the email client and just send the email?
    Thanks
    chuck

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Sending Email (2003 sp2)

    The False argument at the end specifies that the e-mail should be sent immediately, not displayed, and it works that way in Outlook. Which e-mail client are you using? Perhaps it doesn't support or allow automatically sending e-mail?

  3. #3
    3 Star Lounger
    Join Date
    Mar 2006
    Location
    Pittsburgh, Pennsylvania, USA
    Posts
    289
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Sending Email (2003 sp2)

    Lotus Notes. (I am sorry, I always leave out something).
    Thanks
    chuck

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Sending Email (2003 sp2)

    According to this newsgroup thread, Lotus Notes ignores the EditMessage argument of SendObject. The suggestion is to automate Notes, but i cannot help you with that.

  5. #5
    3 Star Lounger
    Join Date
    Mar 2006
    Location
    Pittsburgh, Pennsylvania, USA
    Posts
    289
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Sending Email (2003 sp2)

    I was thinking it was my usual syntax error that was the problem.

    The SAS programmers in my department bypass Notes altogether and send straight to the server. I am going to look into that. But what would I do whithout Woody's Lounge?
    Thanks
    chuck

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •