Results 1 to 8 of 8
  1. #1
    New Lounger
    Join Date
    Jul 2002
    Posts
    15
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Word 2003 Mail Merge (Windows XP/Office 2003)

    We are trying to create a mail merge in 2003. The main document is set up and the data source has been created in Excel 2003. In our data source, we have created two columns that have currency set as the format for one column and percentage set as the format for the other column. The only problem we are having is when it's merged, it does not bring over any of the dollar signs, 1000 separators (comma's) or the percent sign. This work previously in Word 2000/Office 2000. Any ideas?

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Word 2003 Mail Merge (Windows XP/Office 2003)

    One option is to add a format switch to the currency fields in Word:
    - Right-click a merge field.
    - Select Toggle Field Codes from the popup menu.
    - Insert the following before the closing brace } but after the merge field name.
    <code>
    # "$ #,##0.00;($ #,##0.00)"
    </code>
    - Replace $ with the currency sign you need, if necessary.
    - Press F9 to hode the field code and to update the field.

    Another method:
    - In Word, select Tools | Options...
    - Activate the General tab.
    - Tick the "Confirm conversion at Open" check box.
    - Click OK.
    - Go back to step 3 of the mail merge wizard (task pane).
    - Click "Select a different list".
    - Locate your workbook again.
    - This time, you'll be prompted for a method to connect to the workbook.
    - Select "MS Excel worksheets via DDE (*.xls)", then click OK.
    - Continue as usual.
    The nerge should now preserve the number formatting from Excel.

  3. #3
    New Lounger
    Join Date
    Jul 2002
    Posts
    15
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Word 2003 Mail Merge (Windows XP/Office 2003)

    You're a genius!!!!!! Thanks so much!

  4. #4
    Lounger
    Join Date
    Jul 2001
    Posts
    46
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Adjusting the merge codes did it for me, although it caused the data to default to Courier New font, which had to be adjusted - no sweat.

    The second option you mentioned is one I'm still trying to hunt down though, since 2003 menus are so different from the ribbon.

    Thanks,

    Cotton

  5. #5
    Lounger
    Join Date
    Jul 2001
    Posts
    46
    Thanks
    0
    Thanked 0 Times in 0 Posts
    [quote name='HansV' post='641008' date='28-Mar-2007 01:36']Another method:
    - In Word, select Tools | Options...
    - Activate the General tab.
    - Tick the "Confirm conversion at Open" check box.
    - Click OK.
    - Go back to step 3 of the mail merge wizard (task pane).
    - Click "Select a different list".
    - Locate your workbook again.
    - This time, you'll be prompted for a method to connect to the workbook.
    - Select "MS Excel worksheets via DDE (*.xls)", then click OK.
    - Continue as usual.
    The nerge should now preserve the number formatting from Excel.[/quote]

    Found the "Confirm conversion at Open option"
    Clicked OK
    Clicked "Select Recipients"
    Clicked "Use Existing List"
    Selected Excel File
    Got a selection box where I saw only one option - "OLE DB Database files"
    got same result as before.
    Why would I be missing the "MS Excel worksheets via DDE option you mention?

    Cotton

  6. #6
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts
    According to Mail merge with Word 2007, the DDE option should still be available, so I have no idea why it's not present on your PC.

  7. #7
    Lounger
    Join Date
    Jul 2001
    Posts
    46
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I can see the option is available, but it seems to indicate it is only for *.xls files and results in a message "Unable to establish DDE connection". The "Excel Files via ODBC" option, which indicates the availablity for *.xlsx files, results in a message box stating simply that it was unable to open the file - no further explanation.

    Cotton

  8. #8
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts
    I can't explain that - it looks like there's something not installed correctly on your PC.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •