Page 1 of 2 12 LastLast
Results 1 to 15 of 23
  1. #1
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Swanzey, New Hampshire, USA
    Posts
    1,707
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Desktop icon text transparency (XP Pro)

    I was working on a client's Win XP Pro SP-2 PC today and noticed that the text under the Desktop icons was not transparent. All the text had a colored rectangular box instead. I checked in the Display Properties ...... Effects and the item: "Use drop shadows for icon labels on the Desktop" was already enabled, which usually is the setting needed to get the transparency expected. So, what else can I check or do to resolve this problem so that the background is transparent again? I also noticed that the icons suffer from the proverbial "jaggies". I also checked to be sure that the icon size was not altered. But I'm not sure if I was checking in the right place.

    Any help would be appreciated.

    Jeff
    Jeff
    simul iustus et peccator

  2. #2
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Desktop icon text transparency (XP Pro)

    I don't know if you meant display properties or My Computer properties Jeff, but take a look at <post:=509,919>post 509,919</post:> to see if either of those two hints helps. One of the two helped the OP of that thread, but I'm not sure which since he replied to himself...

  3. #3
    4 Star Lounger
    Join Date
    Feb 2006
    Location
    Cape Cod, Massachusetts, USA
    Posts
    408
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Desktop icon text transparency (XP Pro)

    Try right clicking the desktop and then arrange icons by and then unchecking Lock web items on desktop.

    Paul

  4. #4
    Lounger
    Join Date
    Feb 2007
    Location
    columbia, Maryland, USA
    Posts
    28
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Desktop icon text transparency (XP Pro)

    My Computer / Properties / Advanced / settings

    Jeff

  5. #5
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Swanzey, New Hampshire, USA
    Posts
    1,707
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Desktop icon text transparency (XP Pro)

    Thanks all..... when I return to the office this morning, I'll give these suggestions a try. Of course, I would prefer to use the native options (unchecking/checking) to fix the problem, but I have also downloaded a copy of Iconoid and will install that little application should everything else fail. I'll report back with the results. <img src=/S/grin.gif border=0 alt=grin width=15 height=15>

    Jeff
    Jeff
    simul iustus et peccator

  6. #6
    4 Star Lounger
    Join Date
    Feb 2006
    Location
    Cape Cod, Massachusetts, USA
    Posts
    408
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Desktop icon text transparency (XP Pro)

    By the way, if unlocking the items on the desktop does not work try turning off active desktop (if it is enabled):
    Right click desktop
    Properties
    Desktop
    Customize desktop
    Web tab
    Uncheck any web pages present

    Paul

  7. #7
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Swanzey, New Hampshire, USA
    Posts
    1,707
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Desktop icon text transparency (XP Pro)

    Thanks to all who offered help in resolving this problem. The issue is fixed.

    What worked on the problem PC was unchecking the item, "Align to Grid"..... which admittedly baffles me because I have seen that option enabled on countless machines and none have had this issue. <img src=/S/shrug.gif border=0 alt=shrug width=39 height=15>

    Jeff
    Jeff
    simul iustus et peccator

  8. #8
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Desktop icon text transparency (XP Pro)

    That IS weird, Jeff, but I'm glad you got it resolved. I was gonna answer Paul's post by saying that I use "active desktop" to put pictures on my screen and it has not interfered with the transparency of the icon text. That's obviously moot now.

  9. #9
    4 Star Lounger
    Join Date
    Feb 2006
    Location
    Cape Cod, Massachusetts, USA
    Posts
    408
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Desktop icon text transparency (XP Pro)

    Jeff,
    Glad your problem is fixed and your solution baffles me as well as since that setting has no effect on the transparency issue on my computers.

    Paul

  10. #10
    4 Star Lounger
    Join Date
    Feb 2006
    Location
    Cape Cod, Massachusetts, USA
    Posts
    408
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Desktop icon text transparency (XP Pro)

    Al,
    As your experience and Jeff's are different than mine I've got to conclude that this little icon text transparency issue is a bit more complicated than a single setting somewhere.
    The transparency seems to be controlled by several inputs and not just one. So depending on which controls one has checked the text background may or may not be visible.

    First, and I know this is very obvious, but, the background color for the icon text must be set different from the desktop color in order for the lack of transparency to be seen. Thus in experimenting it helps to have some image as wallpaper instead of a solid color. The most commonly referred way to make the icon text background transparent is to:
    Open the Control Panel
    Click System
    Click Advanced tab
    Click Performance settings
    Check "Use drop shadows for icon labels on the desktop"
    OK click your way out

    While that should do it I have found that if you then "lock web items on your desktop" your icon text background is no longer transparent. This locking can be done in two ways I know of:
    Right click desktop
    Click "arrange icons by"
    Click "Lock web items on desktop"

    OR
    Right click desktop
    Click Properties
    Click Desktop
    Click customize desktop
    Click the web tab
    Click lock desktop items

    These are equivalent actions as far as I can tell. While you are looking at Web tab information in the Desktop Items window (the last step in the above procedure) I found that having ANY of the webpages listed there checked , that is, enabling active desktop, will also eliminate the transparent background of the icon text. I would infer then that any other action that turns on active desktop may produce the same result, though I have not played with that. The most obvious of these would be a registry setting.

    So on my systems the "use drop shadows" is a necessary, but not sufficient condition for transparency. I also must have the "lock web items on desktop" AND web pages on the desktop unchecked.
    I would be interested in knowing what effect these setting have on your computer. My results are for XP-Pro and XP-home.

    Paul

  11. #11
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Desktop icon text transparency (XP Pro)

    My icon text is transparent and I can't get it to NOT be so with any of the things you mentioned! I have a solid color background, rather than wallpaper because I do use the desktop for so-called web items i.e. pictures as you can see below. I've tried locking, align to grid and toggling on or off doesn't change the transparency (mine are normally not locked and align to grid is on so I can straighten out the two columns of icons you see). I dunno whassup...
    Attached Images Attached Images

  12. #12
    4 Star Lounger
    Join Date
    Feb 2006
    Location
    Cape Cod, Massachusetts, USA
    Posts
    408
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Desktop icon text transparency (XP Pro)

    Al,

    Given that you have a solid color desktop background, what is the color of your icon text background?

    Paul

  13. #13
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Desktop icon text transparency (XP Pro)

    Heh, heh <img src=/S/blush.gif border=0 alt=blush width=15 height=15> I knew you were gonna ask that and I can't find the place where you select the color for icon text, let alone its background. Can you steer me, please?

  14. #14
    4 Star Lounger
    Join Date
    Feb 2006
    Location
    Cape Cod, Massachusetts, USA
    Posts
    408
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Desktop icon text transparency (XP Pro)

    Right click desktop, properties, desktop, color.
    You can also, I think, just drag an icon over your photograph and drop it there. If the background is not transparent you will see the color. If you do that and it is transparent, then check the lock the icons to the desktop and see it it remains so.

    Paul

  15. #15
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Desktop icon text transparency (XP Pro)

    Sorry I'm just getting around to a post, Paul. Ya know, I don't think (my) desktop icons are "really" transparent after all, but I'm gonna stop now, for this isn't worth too much more effort for naught. It's no wonder I couldn't find icon text background color, for as your reference points out, that's desktop color, not necessarily icon text background. But wait a sec, Big Al, mebbe it IS after all. Here's the things I did. I changed my desktop color to something else (see attachment) - a bright green just for the heck of it. Well, the icon background seems to still be transparent, for it became a bright green also. However, if I do what you suggested and drag an icon over on top of the graphic with the white background, lo and behold the icon text background is still green. I put it back and changed my desktop background to a standard Windows wallpaper and all the desktop icons still show up with green backgrounds. So, the conclusion in MY case is that I don't think those dudes are really transparent at all, they just seem that way because of the common color with the desktop background.

    I suppose I could fiddle some more with turning off active desktop, locking icons and so on, but I'm not gonna bother with it for now anyway.
    Attached Images Attached Images

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •