Results 1 to 10 of 10
  1. #1
    Lounger
    Join Date
    Nov 2006
    Posts
    48
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Personal workbook (Excel 2003)

    Prior to last week, whenever I opened an Excel file, my Personal workbook would also open. For some reason, this is no longer happening, and therefore when I open an Excel file I do not have access to macros stored in Personal workbook. I am not sure what I changed, but clearly something. I did find a workaround solution, in that if I open Excel from Start menu then Personal workbook opens, so at least I can use the macros once again. But I am wondering what can be done so that all my macros are simply available without this extra step, and also why Personal workbook no longer opens automatically?

    Thanks!

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Personal workbook (Excel 2003)

    Try Jan Karel Pieterse's <!post=Systematic Approach to Behavioral Problems in XL,290455>Systematic Approach to Behavioral Problems in XL<!/post>.

    You can also try reregistering Excel:
    - Close all instances of Excel.
    - Select Start | Run...
    - Type <code>excel /unregserver</code> and press Enter.
    - Select Start | Run ... again.
    - Type <code>excel /regserver</code> and press Enter.

  3. #3
    Silver Lounger
    Join Date
    Jul 2001
    Location
    Ottawa, Ontario, Canada
    Posts
    1,609
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Personal workbook (Excel 2003)

    Further to Hans' recommendation, you might also try looking in Help | About Microsoft Office Excel then click on the Disabled Items button.
    Regards
    Don

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Personal workbook (Excel 2003)

    That is a good suggestion in itself, but Olorin mentioned that the problem only occurs when Excel is started by opening a workbook (from Explorer), not when Excel is opened from the Start menu. So I don't think Personal.xls has been disabled entirely.

  5. #5
    Lounger
    Join Date
    Nov 2006
    Posts
    48
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Personal workbook (Excel 2003)

    Thanks. I tried reregistering, and that did not solve the problem, so I'll check out that link you provided and see what I find there.

  6. #6
    Lounger
    Join Date
    Nov 2006
    Posts
    48
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Personal workbook (Excel 2003)

    Thanks. I checked, and there were no disabled items.

  7. #7
    Uranium Lounger
    Join Date
    Jan 2001
    Location
    South Carolina, USA
    Posts
    7,295
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Personal workbook (Excel 2003)

    Here is another suggestion to try.

    1- Open Windows Explorer and then click on Tools in the menu bar then select the Folder options command (what you see may be different since I am doing this on W2K since I do not trust software that includes the Registration/Activation Wizard).

    2- In the folder options dialog box click on the File Types tab.

    3- Scroll down to near the bottom of the file types list until you find the .xls file type and click on it to select it.

    4- Click on the Advanced button.

    5- In the Edit File Type dialog box that appears, click on Open in the list to select it.

    6- Click on the Edit button.

    7- Make sure that the Use DDE box has a tick mark in it. The dialog box should look something like the image below.
    Attached Images Attached Images
    Legare Coleman

  8. #8
    Uranium Lounger
    Join Date
    Jan 2001
    Location
    South Carolina, USA
    Posts
    7,295
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Personal workbook (Excel 2003)

    Hans: When I open Excel from some applications (like when I export a worksheet from QuickBooks), I get this same thing (macros in personal.xls are not available). I have written a reply suggesting that he check Explorer/File Types to be sure that Use DDE is turned on. Can you think of anything else that would cause Explorer to open Excel in a mode that would make personal.xls unavailable?
    Legare Coleman

  9. #9
    Lounger
    Join Date
    Nov 2006
    Posts
    48
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Personal workbook (Excel 2003)

    Thanks, Legare.

    I tried your suggestion, and DDE was already ticked.

    I did manage to find a solution that worked, however: Window / Unhide did the trick, and now Personal.xls opens, and more importantly my macros are available.

  10. #10
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Personal workbook (Excel 2003)

    My suggestion to re-register Excel would also have turned on DDE. Olorin already reported that that didn't work.

    The export problem from QuickBooks could be caused by the way it is programmed: if QuickBooks explicitly starts a new instance of Excel using Automation, you might get a message about Personal.xls being in use.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •