Results 1 to 11 of 11
  1. #1
    New Lounger
    Join Date
    May 2007
    Location
    Stockport, Cheshire, United Kingdom
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    All links to .exe files run as MS Word

    All of the applications on the start menu and desktop now have the MS Word icon, and MS Word is started when you select it.

    I have reset EXE files to be "applications" in the file type association dialogue, but this has had no effect.

    Opening a document DOES open the correct applciation (eg .xls opens MS Excel)

    Any ideas how to fix this ?

    Thanks

  2. Subscribe to our Windows Secrets Newsletter - It's Free!

    Get our unique weekly Newsletter with tips and techniques, how to's and critical updates on Windows 7, Windows 8, Windows XP, Firefox, Internet Explorer, Google, etc. Join our 480,000 subscribers!

    Excel 2013: The Missing Manual

    + Get this BONUS — free!

    Get the most of Excel! Learn about new features, basics of creating a new spreadsheet and using the infamous Ribbon in the first chapter of Excel 2013: The Missing Manual - Subscribe and download Chapter 1 for free!

  3. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 16 Times in 16 Posts

    Re: All links to .exe files run as MS Word

    Welcome to Woody's Lounge!

    Do you have access to another Windows 2000 machine that works OK? If so, do the following:

    - Select Start | Run... on the "working" PC.
    - Type regedit and press Enter.
    - Navigate to HKEY_CLASSES_ROOT.exe and select this key
    - Select File | Export... and export to a .reg file
    - Navigate to HKEY_CLASSES_ROOTexefile and select this key
    - Select File | Export... and export to another .reg file
    - Transport both .reg files to the problem PC.
    - Double-click each of the .reg files.

    This should hopefully restore the normal behavior of .exe files.

  4. #3
    New Lounger
    Join Date
    May 2007
    Location
    Stockport, Cheshire, United Kingdom
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: All links to .exe files run as MS Word

    Thanks Hans, but unfortunately this did not work. I think it probably did something similar to ensuring that EXE files were treated as type application.

    I think that the fact that the application shortcuts on the start menu now all show the Word Icon is significant.

    Also, if you create a new shortcut on the machine (by right clicking in explorer), then it too comes up with the Word icon and starts Word, whatever application you create it for.

    Regards, Roger

  5. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 16 Times in 16 Posts

    Re: All links to .exe files run as MS Word

    Since the problem occurs with shortcuts, you might try the same approach with the registry keys for .lnk and lnkfile.

  6. #5
    New Lounger
    Join Date
    May 2007
    Location
    Stockport, Cheshire, United Kingdom
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: All links to .exe files run as MS Word

    Thanks for this second tip Hans.
    Will try it on Tuesday when I next have access to the machine.

    Regards, Roger

  7. #6
    Silver Lounger
    Join Date
    Apr 2001
    Location
    New York, New York, USA
    Posts
    2,328
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: All links to .exe files run as MS Word

    As I understand, everything is OK with your file associations, but the icons are wrong.

    To fix the problem, refresh the icon cache. You can do it using TweakUI ("Rebuild icons" option), or using third-party utility as REFRESHEM 1.0, or follow the instructions from MSKB 132668
    Icons randomly change to different icons

  8. #7
    New Lounger
    Join Date
    May 2007
    Location
    Stockport, Cheshire, United Kingdom
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: All links to .exe files run as MS Word

    Thanks for the suggestion kaplinb, but this doesn't quite match the problem.

    Yes, the file associations are all correct, so a .xls opens with Excel, and a .ppt open with Powerpoint etc.

    However, it is not that the icons are changing randomly.

    On the start menu, all of the icons for applciations have changed to Word, and also the links are now shortcuts to Word, and so Word is started whenever you select one of them. Further to this, when you create a new shortcut (eg in explorer, sleect Excel.Exe, right click and create shortcut) it is always a shortcut to Word.

    Do you still think that rebuilding the icon cache would fix this ?

    Thanks, Roger

  9. #8
    Plutonium Lounger Leif's Avatar
    Join Date
    Dec 2000
    Location
    U.K.
    Posts
    14,010
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: All links to .exe files run as MS Word

    >>> I have reset EXE files to be "applications" in the file type association dialogue...

    I don't have this entry - is it necessary?

    If you go to your file types association window and click on File Types to sort by application, does Word appear somewhere where perhaps it shouldn't?
    Attached Images Attached Images
    • File Type: gif x.gif (45.7 KB, 4 views)

  10. #9
    New Lounger
    Join Date
    May 2007
    Location
    Stockport, Cheshire, United Kingdom
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: All links to .exe files run as MS Word

    I now have a fix for this problem.
    Hans suggestion of reseting the .lnk and .linkfile parts of the registry did not work, but making sure that windows knows LNK files are shortcuts (in the File Types dialogue of explorer) did.
    Not sure how the user managed to corrupt the system in this way, but I gues that they right clicked on a lnk file, and selected "Open With" Word.
    Here is how it was sorted out:

    Open Explorer (right click on start button and select explore)
    From the menus: Tools -> Folder Options
    Select File Types tab
    Hit the "New" button
    Enter file extension "LNK"
    Hit the "advanced" button
    In the associated file type box select "shortcut" from the drop down (may appear automatically)
    Hit the "ok" button.
    Close the dialogue box.

    This fixed all the shortcuts on the desktop.
    To reset the icons on the start menu it was necessary to reboot.

    Thanks to Hans and Kaplinb for your help.

    Roger

  11. #10
    New Lounger
    Join Date
    May 2007
    Location
    Stockport, Cheshire, United Kingdom
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: All links to .exe files run as MS Word

    Leif asked whether it was necessary to have EXE in the file associations....

    It is not, and after doing the assignment it disappeared after the reboot.
    The same happens with the LNK association (see solution to the problem)

    As the problem is now fixed, I am unable to check whether Word was appearing somewhere that it shouldn't but I suspect from the solution that it may have done :-)

    Thanks, Roger

  12. #11
    Plutonium Lounger Leif's Avatar
    Join Date
    Dec 2000
    Location
    U.K.
    Posts
    14,010
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: All links to .exe files run as MS Word

    Thanks for posting back with the fix!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •