Page 1 of 2 12 LastLast
Results 1 to 15 of 16
  1. #1
    5 Star Lounger
    Join Date
    Nov 2001
    Location
    Jerusalem, Israel
    Posts
    708
    Thanks
    0
    Thanked 1 Time in 1 Post

    On Open not working (2003/2007)

    I installed vista and then office 2003 and then office 2007. Started working again and found that any form that has an on open event will not open and throws an error "object or class does not support the set of events".
    HELP any ideas what is going on?
    Thanks

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: On Open not working (2003/2007)

    Does this happen in both Access 2003 and Access 2007?
    Have you checked Tools | References to see which references are set, and whether any are flagged as "missing"?

  3. #3
    5 Star Lounger
    Join Date
    Nov 2001
    Location
    Jerusalem, Israel
    Posts
    708
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: On Open not working (2003/2007)

    Works fine in 07 and no missing references
    I installed a backup and it worked fine - just one of those things
    Thanks

  4. #4
    5 Star Lounger
    Join Date
    Nov 2001
    Location
    Jerusalem, Israel
    Posts
    708
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: On Open not working (2003/2007)

    It happened on another database and again no missing references and it id not work in 03 but fine in 07. This time a back up did not help. Any other ideas?

  5. #5
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: On Open not working (2003/2007)

    From this thread and your other recent one (<post:=655,223>post 655,223</post:>), I'm starting to get the idea that installing Access 2003 and Access 2007 on the same PC may not be a good idea after all (I have no experience with it myself). It might be better to install each on a separate PC.

  6. #6
    5 Star Lounger
    Join Date
    Nov 2001
    Location
    Jerusalem, Israel
    Posts
    708
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: On Open not working (2003/2007)

    Me too. Maybe I will "steal" my wife's lap top for Access 2003 work.

  7. #7
    5 Star Lounger
    Join Date
    Nov 2001
    Location
    Jerusalem, Israel
    Posts
    708
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: On Open not working (2003/2007)

    In an email from the author he wrote:

    Zave-

    You must start Access 2003 "As Administrator" so that it can reregister itself after you've run 2007.

    John Viescas, author
    Microsoft Office Access 2007 Inside Out
    Building Microsoft Access Applications
    Microsoft Office Access 2003 Inside Out
    SQL Queries for Mere Mortals
    http://www.viescas.com/
    (Paris, France)
    For the inside scoop on Access 2007, see:
    http://blogs.msdn.com/access/


    http://www.mail-archive.com/ms_access_prof...m/msg24719.html

    It's been well-reported that A2007 does not coexist well with earlier
    versions yet. You might have noticed that it takes quite a long time to
    start 2007 after running an earlier version because the process to
    re-register 2007 as the default app hasn't been streamlined yet.

    When you run 2003 and open a databse, it should be using the V11 library,
    not V12. Try changing that, do a compile, and then try to run the app.

    John Viescas, author
    Microsoft Office Access 2007 Inside Out
    Building Microsoft Access Applications
    Microsoft Office Access 2003 Inside Out
    SQL Queries for Mere Mortals
    http://www.viescas.com/
    (Paris, France)
    For the inside scoop on Access 2007, see:
    http://blogs.msdn.com/access/

    How are you supposed to add a reference when access itself is open and will not allow it?

    Thanks

  8. #8
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: On Open not working (2003/2007)

    John Viescas' e-mail confirms my hunch that Access 2007 and Access 2003 on the same PC is not a good combination. I'd either create a dual-boot machine and install each version in a different partition, or use different PCs for the two versions.

  9. #9
    5 Star Lounger
    Join Date
    Nov 2001
    Location
    Jerusalem, Israel
    Posts
    708
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: On Open not working (2003/2007)

    See the fulll post with an explanation of what is doing (or not) in the registry when you try this.
    http://www.utteraccess.com/forums/showflat...&Number=1436960
    Zave

  10. #10
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: On Open not working (2003/2007)

    Does it work for you? This wasn't clear (t me, at least) from your previous reply.

  11. #11
    5 Star Lounger
    Join Date
    Nov 2001
    Location
    Jerusalem, Israel
    Posts
    708
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: On Open not working (2003/2007)

    It seems to be. I will be a bit of work back and forth between 2003 and 07 over the next few weeks and will try it out.
    One thing I did is set 2003 to run as administrator in Vista in general.

  12. #12
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: On Open not working (2003/2007)

    So I assume your question at the end of <post:=655,987>post 655,987</post:> is not relevant any more.

  13. #13
    5 Star Lounger
    Join Date
    Nov 2001
    Location
    Jerusalem, Israel
    Posts
    708
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: On Open not working (2003/2007)

    yes. At least for now. What I assume is happening is that you do not do it manually, but when you are running the program as an admin- you are permitted to write to the registry which when you open Access 2003 it does that for you and changes the reference in the VBA tools, which it could not do if it was not being opened by someone allowed as an admin. Whereas if you are not running as admin then even if Access 2003 opens and reregisters itself it does not change the registry references to VBA and it remains at Access 12.0 references.

  14. #14
    5 Star Lounger
    Join Date
    Nov 2001
    Location
    Jerusalem, Israel
    Posts
    708
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: On Open not working (2003/2007)

    I must say that I feel stupid- but I just upgraded and I cannot figure out how to get 2003 and 2007 to ccoexist on Vista as I did in the past, before downgradig to XP. Any updates.

  15. #15
    Super Moderator
    Join Date
    Jun 2002
    Location
    Mt Macedon, Victoria, Australia
    Posts
    3,993
    Thanks
    1
    Thanked 45 Times in 44 Posts

    Re: On Open not working (2003/2007)

    I have just been attempting to get 2003 and 2007 to coexist on my Vista machine.

    I found I was getting the errors you describe, of On Open events not working.

    But once I set Access 2003 to run as Administrator, the problem seems to have gone away. I have not done much with it yet, but so far it is working.
    Regards
    John



Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •