Results 1 to 9 of 9
  1. #1
    Silver Lounger
    Join Date
    Oct 2002
    Posts
    1,993
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Wrong icon shows for HTML files (Home/SP2)

    This is a little beyond odd. I have Fx 2.0.0.4 installed, and Fx has been my default browser since OS install. The PC also has the latest incarnation of IE7.

    Sometimes it can happen that a default program is changed when a major program is installed. IIRC, when I upgraded to IE7, I was asked when I started Fx if I wanted Fx as default, and answered yes (it had been default since OS install). However, months later I installed Office, and now I am sure it changed default browser. Still a simple task, in this case since I have Fx to check automatically, I was asked first time started Fx after Office install.

    Now for some weeks I have seen the wrong icon for some files. For some reason some files with extension HTML has changed to show IE icon. To make this even more weird, though anything is possible with computers that keep protocol of smallest folder, not all HTML files has the wrong icon. In my own bookmark backups folder [shudder], for some Adobe folders, not all etc. On another partition all have wrong icon.

    The file type is not associated with the wrong program, if double-click a HTML file it opens in Fx.

    This is what I have tried (in order):
    1. Press F5 to refresh folder
    2. Nope, no change
    3. Fx - Tools - Settings - General tab - Check Fx is default browser (not that it should help since it already is default, Fx confirms it is already default)
    4. No, still wrong icon
    5. Use Tweak UI - Repair - Rebuild Icons - Repair Now
    6. No, still wrong icon (fix mess on Desktop, and make <img src=/S/note.gif border=0 alt=note width=20 height=20> to self to always have a clean Desktop ...)
    7. Rebooted
    8. No, still wrong icon (check that IconCache.db is updated, yep it is)
    9. Control Panel - Folder Options - File Types tab; in list for HTM and HTML clicked Advanced, clicked Change Icon, then clicked OK to confirm the selected Fx icon, then OK, next file, OK out.
    10. No, still wrong icon
    11. Rebooted
    12. No, still wrong icon
    <img src=/S/bwaaah.gif border=0 alt=bwaaah width=123 height=15>
    OK, not a monumental problem since file type associate correct, but it shows the same icon as MHT/MHTML that are, and should be associated with IE.

    Any help is appreciated.

  2. #2
    Silver Lounger
    Join Date
    Oct 2002
    Posts
    1,993
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Wrong icon shows for HTML files (Home/SP2)

    I have done a little further research on the PC.

    What I referred to as odd, was that not all HTM/HTML files had changed icon. All files, however, are associated with Firefox, and thus called Firefox document.

    I am almost sure this has to do with my installation of Office XP. As we know Office make use of HTM-files, and this suite apparently has a tool called MSOHTMED.EXE used for editing (printing?). Never heard of it before. Anyhow, the Office suite may have changed some settings.

    I would prefer that HTM/HTML associated with Fx also showed the Fx icon. Also it would be best if it could be solved without direct editing in the registry, since I since latest install have refrained from that. The registry is complex, even though I have some knowledge and done editing before, it can sometimes be hard to cover all places, if the understanding is not 100 %, and it involves both HTM & HTML.

    Just as an example:
    HKLMSOFTWAREClasseshtmlfileDefaulticon shows C:ProgramInternet ExplorerIEXPLORE.EXE,-17. (Note Swedish OS, thus C:Program, not Program files).

  3. #3
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,572
    Thanks
    5
    Thanked 1,057 Times in 926 Posts

    Re: Wrong icon shows for HTML files (Home/SP2)

    You should be able to use Windows Explorer - Tools | Folder Options | File Types and change both the default program and icon.

    Joe
    Joe

  4. #4
    Silver Lounger
    Join Date
    Oct 2002
    Posts
    1,993
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Wrong icon shows for HTML files (Home/SP2)

    Joe,
    Thanks for reply. I will try to take a look at that. As I mentioned, I earlier just re-confirmed the chosen icon. Did not try to set it to something else, or change default program.

    I omitted one thing I found at file types; both HTM & HTML have edit, print and open as actions associated, in the Tools > Folder Options > File Types > Advanced. These are the options, as you know, one will find if right-clicking a file (together with standard action via double-click).

    HTM & HTML
    edit "... Office10msohtmed.exe" %1
    print "... Office10msohtmed.exe" /p %1
    open ... MOZILL~1FIREFOX.EXE -url "%1" -requestPending

    The icons may have changed when Office was installed, and these actions were added. Still odd that I can find files with correct Fx icon and many with the IE icon.

    OS, most programs and Fx are Swedish, Office and some programs are English.

    These commands (in file types) are written in English, but on the context menu the Open command is written in Swedish (Fx is Swedish), the others in English. That is: the available commands under File Types are always written in English in my Swedish OS, for all file types. But depending on language in programs the language on the context menu can shift. Common knowledge maybe, and I have known this, but it can indicate why the icons are wrong.

    Added: Changing icons to something else within the Firefox.exe, and rebooting did not change icons for these file types.

  5. #5
    Silver Lounger
    Join Date
    Oct 2002
    Posts
    1,993
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Wrong icon shows for HTML files (Home/SP2)

    You will not believe this.

    I have looked at the change icon again (Folder Options > File Types > Advanced), only changing from one Fx icon to another and back again. Did not help.

    I was, and I am puzzled how it could show different icons for the same file type. I.e. on the different partitions most showed wrong (IE) and some showed right (Fx), true for both HTM and HTML.

    When I looked at a folder that had the right Fx icons, it happened it had quite a number of files (not extreme but >125) and Windows had decided to use Icons as View Option. To view the extra information for all files I changed View Option to Tiles, now the files showed the wrong icon! See screen shot.

    Headed over to one of the folders where I first noticed wrong icons (IE), sure enough, they were showing in Tiles view and if I changed to Icons view, they showed Fx icon.

    It seems that:
    Icons, List and Details View show the right icon,
    Tiles and Thumbnails View show the wrong icon.

    Something is obviously not working. <img src=/S/scratch.gif border=0 alt=scratch width=25 height=29>
    Attached Images Attached Images

  6. #6
    Plutonium Lounger Leif's Avatar
    Join Date
    Dec 2000
    Location
    U.K.
    Posts
    14,010
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Wrong icon shows for HTML files (Home/SP2)

    I believe it <img src=/S/laugh.gif border=0 alt=laugh width=15 height=15>

    OK, how about this as a theory: Presumably the icons are held in different sizes somewhere, depending on what view you choose, Tiles, Details etc.
    I also presume that these are different sizes - 16 x 16, 48 x 48 pixels etc.
    But what if there are no 'large' Firefox icons on your system? Will it display an alternative (i.e. IE)?

    (I appear to have consistent icons whatever the view.)

  7. #7
    Silver Lounger
    Join Date
    Oct 2002
    Posts
    1,993
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Wrong icon shows for HTML files (Home/SP2)

    Hi Leif believer <img src=/S/smile.gif border=0 alt=smile width=15 height=15>

    Could be. Well I was going to write about this "different sized icons"; that they come in different sizes. I should know this and have read about it, but then stupid me thought: but they do look the same size in the File Types > Advanced icon dialog, so maybe there is one size and they scale. Stupid. So I removed that before posting.

    Anyhow, I have not checked every folder on every partition that holds HTM/HTML-files, but checking 4-5 confirmed what I wrote earlier.

    Sometime when I upgraded to Fx2 (2.0.0.2) I saw a little change in icons; in this case if I compared a saved HTM-file and a link/shortcut to a web page, both at that time of course had a Fx Icon, but one had the "fox and the white paper behind", the other (don't remember, maybe the web link) had only a big Firefox icon. This is how the files/links looked when placed on Desktop. Nice I thought, they look different. Now some Fx updates later all have the "fox logo and the white paper".

    So maybe I am complaining about Office installation or Windows issues, and it can be a Fx issue ...

    But you must agree it's weird to see another icon when you change view <img src=/S/laugh.gif border=0 alt=laugh width=15 height=15> <img src=/S/hmmn.gif border=0 alt=hmmn width=15 height=15> <img src=/S/nuts.gif border=0 alt=nuts width=15 height=15>

  8. #8
    Silver Lounger
    Join Date
    Oct 2002
    Posts
    1,993
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Wrong icon shows for HTML files (Home/SP2)

    Leif and everyone,
    As we saw in my last posts, somehow Windows cannot show the correct icon when the folder view is set to Tiles (or thumbnails), i.e. when the folder needs large icons.

    I don't know what has caused this and how to solve it (no surprise, that is why we post at the Lounge, but some problems (for me) sure are easier).

    So, it could be anything, an update, though a program installation is the most probable. Annoying, since I have not that many installed and have installed in steps to make sure everything is working nicely. Can't say for sure, but I don't recall seeing this before Office installation, so somewhere in May.

    I tried another old trick, change the color depth then change back, but it did not help.

    Then just for the heck of it (though I didn't think it would solve it) I set IE as default browser. Now all HTM/HTML-file icons showed IE icon. I then changed back to Fx as default, (starting Fx with setting to check at start, and click Yes). Nope, wrong icons in Tiles view etc.

    So, how can I find out if "large" icons are missing? What do you all find when looking for icons in the firefox.exe?

    As you assumed Leif, when Windows doesn't find an icon (whatever) it instead presents the IE icon. This can be seen when I go to a folder in Windows Explorer for the "first time", then there is a very slight delay before the IE icon is shown for the HTM/HTML files.

    Of course one could run around and try this and try that; remove Fx, d/l a new copy, clean install etc. But this machine has been kept tidy, and I don't want to start to make mess. Some plugins are easy to replace in Fx (if remove and reinstall Fx), but others have been "installed" when later installing a program, as Adobe Reader, WMP 11 etc. etc.

    Over at MozillaZine Forum there is a thread: Windows Doesn't Display Firefox Icon for HTM or HTML files, but the poster got blank, generic icons instead of IE. The cause was a wrong registry value data, due to some DOS 8.3 naming convention and the use of several Mozilla products/installers.

    Then there is this promising subject: IE icon instead of Firefox icon, but no solution in there.

    Then we have this thread at TechRepublic: IE html file icon displayed instead. No solution, and I have already tried what they sugest.

    I have also looked at the Lounge thread: <!post=Explorer Icons (XP Pro SP2),605785>Explorer Icons (XP Pro SP2)<!/post>. In my case HTM & HTML files are Firefox Document types, not HTM Document.

    So far as I have seen, those who have problems with an IE icon instead of Fx, has not mentioned anything about different result if changing folder view (my case). So either they have a slightly different problem, or they have not looked close enough and are showing all folders in Tiles or Thumbnails (not likely).

    <img src=/S/help.gif border=0 alt=help width=23 height=15>

  9. #9
    Silver Lounger
    Join Date
    Oct 2002
    Posts
    1,993
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Wrong icon shows for HTML files (Home/SP2)

    Solved.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •