You need to update QuickTime and Flash now

Apple have released V7.2 of QuickTime that patches eight serious flaws in the product the worst of which could allow your computer to compromised simply by watching a specially crafted QuickTime movie. More details here [1]. If you QuickTime version number is less than 7.2 then please update from here [2] now. Adobe has also released a patch for its highly popular Macromedia Flash plug-in. This fixes flaws in Flash that, like the QuickTime flaw, could allow your computer to be compromised simply by watching a malicious Flash movie. According to the Adobe bulletin the flaw affects "9.0.45.0 and earlier, 8.0.34.0 and earlier, and 7.0.69.0 and earlier." You can update from here [3]. These flaws are serious folks; please update immediately.
[1] http://docs.info.apple.com/article.html?artnum=61798
[2] http://www.apple.com/support/downloads/
[3] http://www.adobe.com/support/security/bulletins/apsb07-12.html