Results 1 to 3 of 3
  1. #1

    Missing string function reference (Access 97 SR2)

    I have an update query that uses the left, mid and right functions to cut up a text field. It used to work fine. But now when I run it I get type conversion errors. I copied the table to a new database and run the same update query - it worked fine. It seems there are missing references to those string functions in the original database. Is there any way to check and replace these. The database has too many tables queries and reports to be easily copied to a new database. I have compacted and repaired it. It did not help.

    Help please anyone.

  2. #2
    Gold Lounger
    Join Date
    Jun 2001
    Crystal Beach, FL, Florida, USA
    Thanked 41 Times in 40 Posts

    Re: Missing string function reference (Access 97 SR2)

    You are right when you say Access has lost it's references. To fix, just open any module or go into De######. Then from Main Menu Bar, select Tools | References. Scan the list for any reference listed as "Missing". Make note of which one it is, then uncheck it and and close the box. Now, open the list back up again and find that same reference. Select it and close the box again. This should clear-up the problem.
    Mark Liquorman
    See my website for Tips & Downloads and for my Liquorman Utilities.

  3. #3

    Re: Missing string function reference (Access 97 SR2)

    Thanks - it now works again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts