I've just done a clean install of XP to SP3, after a HDD failure

Everything was going along swimmingly, until a short while ago

As part of the process, once I've got all Win updates onboard, I then move on to the Optimization of the System, using things like SafeXP, xp-antiSpy, TuneUp Utilities System Control; I also use Partitions, which I've optimized using Easus Partition Master and do some Registry Cleaning and optimization with a 3 year old version of jv16 Power Tools; usually very safe and reliable; and once it's up & running safely, I use Doug Knox's Hotfix Backup Removal Utility

I'm not sure which of these caused the problem (perhaps Easus or TuneUp, both usually very reliable) but I now have no Drive Icons under Windows Explorer:

At first, I wasn't even shown 'Computer' and the drives under it! Just the Desktop and the folders there; and on my Start Menu, nothing I do will show my 'Computer' on the Start Menu

This has all kinds of follow on probs; Saving things via my Edited Places Bar....

...means I can actually save things where I want, but if the Places bar isn't set to show during a save, I can't - it has to be the Desktop

At first, I thought this had to do with the Security 'Permissions' Properties; When the HDD failed, I needed to get something up and running in a hurry (My whole life's on the damn thing!) so went with my Christmas Present of Win 7, despite feeling it was too early for my liking; In my hurry -and due to a outbreak of general stupidity- I messed up the Security Permissions and found it a nightmare to sort out, once I'd calmed down, so much so, I went back to my old, trusty XP, on a different, new HDD

Despite that, I'm convinced some ghost in the machine is carrying over some aspects of previous installations, something I've thought before; this isn't as daft as it sounds, since, one of the many benefits of Partitions\Multiple HDD's is Data security (Along with Quick Daily multiple Security Scans of the most vulnerable areas; quick, small, daily Image backups; Games can be easily re-used by just re-entering the serial, they don't usually need reinstalling; General Data Security etc etc); all I lost with the failed HDD was my OS Partition, my Program Files Partition and some Archives of DVD's, Games etc. The other partitions, such as Data, Games, Media, Backups were all re-utilized with Win7 (And Yah-Boo-Sucks to the 'Anti Partition Brotherhood'!)

I found a problem with the 'Creator\Owner' Security Permissions, so removed them and tried using my account name (which is Admin) on all Partitions, along with an Everyone LUA account, System, Administrator, Users, Authenticated Users, but I can't say I've ever completely understood these Permissions in their entirety

So, it's still not working right - and on other, preferred File Managers...

<<< Oooops! Sorry 'bout that!

..It's even worse, as the Tree View doesn't even show the drives under Computer; and I can only get at the other Partitions via the Address Bar, previously setup Hot Keys etc, but it's not ideal and I'd like to sort the problem

I should also mention, I've an application that needs to write to My accounts' Local settings Folder, but that is stuck at 'Read Only' and I can't switch that off permanently, for some reason.....

So maybe, it's not the Security Permissions; I've removed all the backups for the Updates I applied, seemingly successfully, so can't undo them and see if that's the prob; the Reg Cleans I have as Backups, so can be re-merged with the Registry, but I've checked them and can see no reason for this; I've checked the other things I used and can see no reason for them to be the cause

Is this likely to be a Security Permissions problem? Can I solve this with a simple Registry Edit? Is this a known XP prob I just haven't come across before?

I should mention, I had Easus Partition Manager open and was about to hide my Dedicated Swap Partition, so it wouldn't show in Explorer etc, but coudn't remember whether this was a good idea or not (whether it invalidated the Swap Drive or not....?) So I had set it to 'Hidden' but then undid that and it seemed to be after that that I noticed the problem; but I wasn't convinced this caused the problem and nothing I can do with this tool seems to have the reverse affect or similar

All help much appreciated, so long as you don't tell me I need to do another clean install! (I HATE having to do that!)

Thank you