I recently had my slave hard drive fail. I replaced it with a new one that is much bigger. When I went to restore my data from Norton Ghost 2003 backups, the D-drive restored just fine. None of my other partitions would restore backup-to-partition. In fact, in the Ghost restore screen, I could select the new hard drive but could not individually select any of the six individual partitions.

After replacing the hard drive, I did a backup of my master hard drive to DVD without any problems. When I tried to run a backup to an empty partition on the slave drive, Ghost acted like it would run, letting me select the subdirectory and all but when it booted to PC DOS, it almost immediately aborted and returned to Windows.

At one point in doing something (I forget what) I got an error message that Ghost saw my new partitions but they were unregistered and I suspect that is the issue, especially since I did this before the HD swap without a problem and only the HD changed. However, for the life of me I cannot find an option in the Windows shell for Ghost to register them.

I tried going to the Symantec website but they no longer support Ghost 2003 and seem to be mostly out of the consumer imaging market. Can anyone help?

If it matters, I am running XP. The old slave hard drive that failed was a 500 GB SATA drive and the new one is a 1.5 TB SATA drive. I cannot tell which build of Ghost I have because the help menu gives me information on the Norton suite I have rather than Ghost but I have downloaded the update for working with SATA drives.