Results 1 to 6 of 6
  1. #1
    New Lounger
    Join Date
    Dec 2009
    East Lynn, West Virginia, USA
    Thanked 0 Times in 0 Posts
    Has anyone else had problems installing Silver Light update version 4.0.50917.0 from Windows Update? I'm running Win 7 Pro. 64 bit, AMD Phenom 9950 Quad-Core Processor. This update failed, and Silver Light no longer worked (Netflix wouldn't play movies, message said it needed Silver Light).

    Microsoft support : completely uninstall Silver Light with Windows Installer Cleanup Utility. Reinstall Silver Light. It didn't work, error code 1603 when trying to reinstall. I then found that I could no longer install any program. At this point I'm tired of fooling with it and decided on a clean reinstall of Win 7. That fixed everything and when the Silver Light update appeared at Windows Update I ignored it...I'm still ignoring it.

    Meanwhile, MS support has sent me a page of instructions that I will paste at the end. I replied that I had done a clean install and Silver Light was working again (the update had not yet popped up on my Windows Update).

    My husband, who has an almost identical system to mine, tried to do the Silver Light update and experienced the same problem. MS support sent him the same suggestions, which he tried, but with no luck. He is still emailing back and forth with MS trying to resolve the issue.

    Any ideas why we've had this problem? Anyone else having a problem with the download?


    Microsoft's 2nd try at fixing the problem:

    Based on current situation, the most likely cause is that the current user account does not have the correct permissions to access related folders and registry keys. At this point, I suggest we first try the steps below to reset the default permission on those folders and registry keys, which will be accessed when installing Silverlight:

    1. Please download the subinacl.msi file from the following link and save the installation patch on the Desktop:

    2. Please go to the Desktop and double click the downloaded file.

    3. Please select the C:\Windows\System32 folder as the Destination Folder during the installation. Later we will use this tool to reset the permission settings on the current machine.

    Note: If UAC (User Account Control) window is prompted for permission to continue, please click "Continue".

    4. Click "Start". In the Start Search bar, type: "notepad" (without quotes) and press Enter.

    5. Copy the following commands and then paste them into the opened Notepad window:

    @echo off

    subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f

    subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f

    subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f

    subinacl /subdirectories %SystemDrive% /grant=administrators=f

    subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=system=f

    subinacl /subkeyreg HKEY_CURRENT_USER /grant=system=f

    subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=system=f

    subinacl /subdirectories %SystemDrive% /grant=system=f

    @Echo =========================

    @Echo Finished.

    @Echo =========================


    6. After pasting the above commands, please close the Notepad window. Choose Save when you are prompted to save the file. Type "reset.bat" as the file name and choose Desktop from the left panel as the save location.

    7. Refer to the Desktop and right click the reset.bat file, then choose "Run as administrator."

    8. You will see a DOS-like window processing.

    NOTE: It may take several minutes. When it is finished, you will be prompted with the message: "Finished, press any key to continue".

    9. Please restart the computer and install Silverlight again from to the following website:

    Does Microsoft Silverlight install properly? If not, please follow the steps below to collect Windows Installer log:

    1. Click Start Button, type "cmd" in the search bar. The CMD icon will appear in the Start Menu.

    2. Right click the CMD icon and click "Run as administrator".

    3. In the popup window, copy and paste the following command then press Enter:

    REG ADD HKLM\SOFTWARE\Policies\Microsoft\Windows\Installer /v Logging /t REG_SZ /d voicewarmup /f

    4. Click OK or press Enter to run this command.

    5. Restart the computer.

    6. Try to install Microsoft Silverlight again.

    7. If it fails, click Start, type "%temp%" (without quotation marks) in the Search Bar and press Enter.

    8. Please send all "XXXXXMSI.log" files to me

  2. #2
    Super Moderator Deadeye81's Avatar
    Join Date
    Dec 2009
    North Carolina, USA
    Thanked 113 Times in 97 Posts
    Hi Maria, and welcome to the Lounge!

    Did you and your husband send MS your system specs? Have you checked the support forums at AMD for any posted problems with Silverlight like you are having?

    Silverlight is fully patched and operational on my systems. I can understand your reluctance to accept another Silverlight update.

    Use Windows 7 Backup software to do a system image of your Windows 7 installation to an external USB hard drive in case something like this happens again. Be sure to create the Windows 7 Repair disk located on the Windows Backup screen. This disk will be used to restore your image backup should the need arise to do so. Doing this can eliminate the aggravation of a new full system install. This is not to suggest that an image backup is the only solution to your issue, but it is a good practice to maintain in any event.

    Other loungers will be along, and some may have experienced the same difficulty.

    "We make a living by what we get, we make a life by what we give." Sir Winston Churchill

  3. #3
    Super Moderator CLiNT's Avatar
    Join Date
    Dec 2009
    California & Arizona
    Thanked 609 Times in 557 Posts
    Ditto to Gerald in the above post here.
    I have Windows 7 64 bit running the same version 4 of Silverlight without issue.
    Intel platform. I went to Netflix to confirm operability with my 32 bit browser, as I have not been there for some time, and it works well enough.
    Invest a little time and energy in a well thought out BACKUP regimen and you will have minimal down time, and headache.

    Build your own system; get everything you want and nothing you don't.
    Latest Build:
    ASUS X99 Deluxe, Core i7-5960X, Corsair Hydro H100i, Plextor M6e 256GB M.2 SSD, Corsair DOMINATOR Platinum 32GB DDR4@2666, W8.1 64 bit,
    EVGA GTX980, Seasonic PLATINUM-1000W PSU, MountainMods U2-UFO Case, and 7 other internal drives.

  4. #4
    New Lounger
    Join Date
    Dec 2009
    East Lynn, West Virginia, USA
    Thanked 0 Times in 0 Posts
    Thanks for the replies. I am currently running SilverLight 4.0.50826.0 with no issues. It's the update for 4.0.50917.0 where the problem occurs. Everything works fine, including NetFlix. It's just irritating that there's an update out there that for some reason won't work with my system. And, yea, backups are done There's a new crop of updates out there.

  5. #5
    Join Date
    Mar 2001
    St Louis, Missouri, USA
    Thanked 1,198 Times in 1,043 Posts
    I found the following suggestion at Error code #1603 : The Official Microsoft Silverlight Site:

    "Had the same problem, no other suggestion worked. However, this is how I
    fixed it.
    Open regedit and navigate to "HKEY_LOCAL_MACHINE\Software\Microsoft\Interne t

    It will say you do not have permissions, so right click and add yourself will
    full control.

    Silverlight should install now, at least it did for me."

    NOTE: on the one machine where I had an install problem with that update, I used the control panel applet to uninstall the 4.0.50826.0 version then went to Get Silverlight | Microsoft Silverlight to install the current version


  6. #6
    5 Star Lounger petesmst's Avatar
    Join Date
    Dec 2009
    Cape Town, South Africa
    Thanked 51 Times in 40 Posts
    I had this probem with IE8. Eventually I simply gave up and left things as they were (Silverlight un-installed and no further attempt to install the latest version). I then downloaded and installed IE9 Beta, and all is now fine with Silverlight up and running(!?)
    (My Setup: Custom built: 4.00GHz Intel Core i7-6700K CPU; MSI Z170A Gaming Carbon Mobo (Military Class V); Win 10 Pro (64 bit)-(UEFI-booted); 16GB RAM; 500GB SAMSUNG 960 EVO M.2 NVME SSD; 512GB SAMSUNG 850 PRO SSD; Seagate 2TB Barracuda SATA6G HDD; 2 X GeForceGTX 1070 8GB Graphics Card (SLI); Office 2016 Prof "Click to Run" (32-bit); Acronis TI 2017 Premium, Norton Internet Security, VMWare Workstation12 Pro). WD My Book 3 1TB USB External Backup Drive). Samsung 24" Curved HD Monitor.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts