Results 1 to 3 of 3
  1. #1
    New Lounger
    Join Date
    Oct 2010
    Orem, Utah, USA
    Thanked 0 Times in 0 Posts
    I've been having a strange problem that all sorts of in-depth troubleshooting doesn't seem to solve: When I try to install the 2008 C++ runtime on Win 7, MSI aborts almost immediately with a 1935/80070003 error. So, I used a .REG file to turn on MSI logging, and found the part where the error happens. An 80070003 error means "path not found," but WHY has me stumped.

    The reason I'm installing this is convoluted: I was running Trend Micro Internet Security, and nothing's ever got past it. They sent me a free upgrade to their new Titanium 2011 package, so I uninstalled the TMIS 2010, but then when I tried to install the Ti package, it said it was installing the 2005 Virtual C++ runtime which was already on the machine, and aborted. Then, the 2005 runtime was gone, and attempts to reinstall it from the MS installer crashed with the 80070003 error.

    So, I then ran Aaron Stebner's .NET checker and the System Readiness Tool. The former said all was fine with .NET, but the latter flagged a missing %windir%\winsxs\manifests policy manifest for VC90 that I happened to have on another Win 7 installation, so I copied that over, and now I can install/uninstall the 2005 SP1 runtime fine, but when I run Windows Update, it whines that needs a security update, and when I give it the go-ahead to install that, it fails, and the 2005 runtime disappears from Programs & Features! I can reinstall it fine, though, so I disabled that runtime security update in WU for now.

    But, if I then try to install the 2009 C++ SP1 runtime, that fails as described above. I've attached a copy of the 2009 redist installation MSI log (see lines 1680 - 1692), and a .txt clip of the related section of the .cbs log. Installing that runtime even fails from an msconfig-set completely vanilla startup, with the MSI service started manually.

    Because of this, I had to install MS Security Essentials, which installed and works fine, so the MSI engine doesn't have a problem: It's VC++ related only. Can someone point me in a direction to solve this? Something has to be out of sync in the installation data, and I've no idea of how to recover it. Thanks.
    Attached Files Attached Files

  2. #2
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Thanked 937 Times in 856 Posts
    I wonder if a Win 7 repair install would help your problem. Insert the Win 7 DVD or the Repair disk you made (through Win 7 Backup and Restore), boot to the DVD, work through the time settings, then do the Repair Install. This may fix something that got corrupted when the Trend Micro install was aborted. Just a guess, but I have seen the Repair Install fix some very strange problems. You also might consider creating an Image once everything is fixed and running properly, then recreating a new Image whenever changes are made. Read about this in the Security and Backups forum.
    Have a Great Day! Ted

    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)

    Complete PC Specs: By Speccy

  3. #3
    Gold Lounger
    Join Date
    Oct 2007
    Johnson City, Tennessee, USA
    Thanked 215 Times in 202 Posts
    Quote Originally Posted by Helge Skjeveland View Post
    "path not found," but WHY has me stumped.
    Hello... Just a guess this is way over my "paygrade". Sometimes when I'm trying to install programs i get errors like that, and it seems that at times it's a "permission thing" that stops the install. I have to find where the program "choked" and "take ownership" of the folder \ file, and try again ....Sometimes it will proceed or at least go on a bit further. I have seen this even when you can "see the path" Regards Fred

    None are so hopelessly enslaved as those who falsely believe they are free (J. W. Von Goethe)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts