Results 1 to 2 of 2
  1. #1
    Star Lounger
    Join Date
    Jun 2001
    Thanked 0 Times in 0 Posts

    Macros in Excel (Excel 2000 SR-1)

    Before the recent WOW issue about creating a macro to paste unformatted text, I was trying to do it on my own. Once I got one that sort of worked, it didn't work all the time, I just created it in each of the excel files I use.
    Then I saw the WOW issue and realized I could just put one macro into my personal.xls file, and not have to have one in every file. I created the PasteUnformatted macro and put it in the personal.xls file. Then I went and deleted all of the workbook specific macros.
    I re-made the pasteunformatted macro a couple times, and had to delete the personal.xls file, since it wouldn't let me delete the macro through excel.
    Finally, after all that, I just deleted all the macros, and deleted the personal.xls file.

    Now when I try to open the excel files, that originally contained my PasteUnformatted macros, it still thinks they are there and asks whether or not to enable or disable them. When I go to the Tools | Macros | Macros, there are none there.
    Is there any way to make these files know they don't contain any macros?

    Justin K.

  2. #2
    Gold Lounger
    Join Date
    Feb 2001
    Dublin, Ireland, Republic of
    Thanked 0 Times in 0 Posts

    Re: Macros in Excel (Excel 2000 SR-1)

    When you created the macros they resided in a code module, Module1 etc. When you delete the macros you do not automatically delete the modules. When you open a workbook that has modules (even empty ones) Excel assumes that the file contains macros.

    When you open these files go to the VB editor (Alt-F11) and look in the window on the left (Project Explorer) for any modules and delete them (just ensure thay are in fact empty and do not contain any code that you might have use for). This should help resolve the problem.

    Andrew C

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts