Results 1 to 2 of 2
  1. #1
    New Lounger
    Join Date
    Dec 2008
    New Orleans, Louisiana, USA
    Thanked 0 Times in 0 Posts

    problem using excel w/macros over vpn

    I'm using a laptop with XP and Excel 2003 and connecting to a corporate network through VPN. They just created a spreadsheet with macros that is supposed to automate some of what I do. I can't get it to work and I think it's probably some simple setting in excel. Their tech people and even the creator of the form can't figure it out.
    The spreadsheet resides on the V: drive of their network and I have read only access. I was told to open the ftp site and then save the folder to my favorites and then create a desktop short cut from there. I did this and can open the spreadsheet sometimes but when I try to submit it, it's supposed to send a copy to their V: drive (which I don't understand if I have read only access but I'm not a macro person). When I click the submit button, the pointer just hangs and won't do anything. The correct ftp path shows on the form, but excel won't complete the submission.
    What I think might be happening is that I was not given instructions at first and I saved the spreadsheet from the V drive to my local drive. It worked okay until the submit button and then I had to force Excel to shut down. When I tried to re-open it, the file was in the disabled items field and I got a note that it caused a major problem the last time it was opened. I tried saving it again and then deleting it and going about the process the way the instructions said when I finally got them. I can't find the form anywhere on my local drive and I'm not allowed to delete it from their V: drive. Could it be some setting in Excel that is causing this to happen?
    I know it's a wordy request but I can't really figure out how to express the issue. I would appreciate any help.

  2. #2
    3 Star Lounger
    Join Date
    Nov 2002
    New York, New York, USA
    Thanked 20 Times in 20 Posts

    A few suggestions.

    1. Open Excel, make sure that the security level for macros is set to the lowest setting. Tools - Options - Security - Macro Security - Low (make a note of the default setting on you machine.)
    2. Is the VPN Workbook an Excel 2003 version? If its a 7 or 10 version the Macro may not work. Ask that a 2003 version be put on the V: Dirve
    3. Check other workbooks on your local machine and make sure they run Macros, if not your version of Excel may need to be reinstalled.
    4. If you don't have a workook with macros, open a trusted workbook record a new Macro (example record how you instruct Excel to print out a few lines of text)
    Stop the recording and then run the Macro. If Excel won't let you record, or the Macro fails to work when you run it again, then there is a problem with your Excel.

    5. If Excel is working fine with the Macro's on your local computer, then go out and open the Read Only version of the Target Workbook on your machine.
    Before saving this workbook test the Macro by making a few changes and running the macro. If all is well then delete the changes and save the workbook on the local machine.

    6. Very Important, no matter what happens make sure that you Set Excel's Macro security level back to its default settings! Of couse to run Macro's you may need to change it to the lowest level. But always end an Excel session by putting back the default settings. Your machine and IT group will very much appreciate this.

    I hope the above is some help. If not have your IT folks double check by opening the exact workbook you are using in ("Read Only") Mode, and Test the Macro and Workbook to ensure that something has not gone wrong.

    Good Luck

    Tom D

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts