Results 1 to 2 of 2
  1. #1
    Join Date
    Dec 2009
    Edmonton, AB, Canada
    Thanked 2 Times in 2 Posts

    Thumbs up USB hard drive not recognized

    Good day to all.

    My WIn 7 Pro 64-bit box has started to not recognize my external USB hard drives. It started off with one USB port being a problem and has since increased to 2 ports being problems.

    I've been using 3 or 4 different types of USB drives and enclosures: Seagate Free Agent Go (500GB, 640GB) and some generic 2.5" IDE enclosures (all identical). The generic enclosures date back from my Win98 days but have always worked in all of my machines, including this one, since it was new. Same with the Free Agent Go drives. But not anymore.

    Upon plugging the drive in, I get the familiar Boink sound, usually followed by a popup message saying that the driver is installing, followed by another message that says that the USB device is not recognized and that a USB device has malfunctioned. A final popup says that the driver installation was not successful.

    Bringing up the Device Manager shows flags on one or more of the USB entries. Right-clicking on an affected entry and selecting Properties shows that the device has malfunctioned and that Windows has stopped the driver (Code 43).

    I've spent some time Googling for this and have tried several things:

    1) Uninstall the driver (in Device Manager) and plug the drive back in - this theoretically reinstalls a working driver. Nope - it doesn't.

    2) Similar to above, but browse to the Windows winsxs directory and reinstall from there. No help either.

    3) Also similar to above but allow Windows to go looking online for a working driver. Windows always comes back and says that I have the proper driver installed.

    4) Made sure that the "usbstor.inf" file is still present on my machines. Yep - in a bunch of different locations but all the same size: Windows\inf; Windows\System32\DriverStore\FileRepository\usbsto r.inf_amd64_neutral_ <bunch of numbers> (2 entries); Windows\winsxs\amd64_usbstor.inf_ <bunch of numbers> (6 entries).

    I'm not sure why there are references to amd64 - this is an Intel Q9300 processor and Intel chipset on the mobo. But the file dates are all old, which makes me think that the files have been there from the start and simply have nothing to do with my current system configuration.

    Bringing up the Device Manager shows two USB ports as flagged. There are 6- USB ports listed 2934 thru 2939 as well as 2- USB2 ports (293A & 293C). USB ports 2937 & 2938 are the flagged ports.

    What I've been doing is right-clicking on those ports and uninstalling them. With the USB drive NOT connected, I then right-click on the listed ports and select "Scan for hardware changes". This brings the missing ports back again. Plug the drive back in again - the whole cycle repeats.

    Now I'm not sure how to proceed.

    I should mention both drives that I am playing with right now (Seagate Free Agent Go 640GB and generic USB 2.5" drive enclosure) work just fine on the Win XP Pro 32-bit machine sitting right next to the Win 7 box. I'm pretty certain that its not the drives <grin>.

    Any suggestions or help gratefully accepted.

    Many thanks!


  2. #2
    Join Date
    Mar 2001
    St Louis, Missouri, USA
    Thanked 1,201 Times in 1,046 Posts
    Have you tried displaying hidden devices in Device Manager and removing anything to do with the USB drives?

    Have you tried removing the USB hub in Device Manager and letting Windows reinstall it?


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts