Results 1 to 2 of 2
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Thanked 2 Times in 2 Posts

    Comodo Firewall 6.2 corrupting Win 7 x64

    Hi all,

    Had lots of problems today when Comodo Firewall tried to upgrade itself to 6.2 from 6.0. The faults are all reproducible.

    It is an Asus Gaming laptop G75V, Win 7 x64 12GB RAM & 2 x 750GB HDDs. Windows fully updated, running MS Security essentials and no other security software.

    When I clicked for Comodo to update itself (I have only the firewall, NOT their security suite) it began to install and hung the computer. I could not recover from it, even Ctrl+Alt+Del could not help with the completely black screen. The disk access LED kept flashing the same pattern, as though it was constantly reading or writing the same data.

    I had to hold the power button to close it down. When windows started up, it asked if I wanted to check for problems. I said yes and it found some file integrity problem. It said it could do nothing about it and did I want to restore? I said yes and off it went.

    It came back that the restore had failed. I had to reboot and thankfully windows rebooted after some time. My windows image was gone, it said that it had been interrupted while making the image. So that would explain the failure of the restore operation.

    I suspect that possibly Comodo had tried to update while the computer was doing a back-up image and possibly that explained things? So I made sure it was not currently backing up and got Comodo to update manually.

    Exactly the same things happened all over again. Once I could get into windows again, I uninstalled Comodo firewall and installed the latest version manually rather than updating. Everything seemingly went fine.

    I went to download today's free game from and installing it required giving about 15 different permissions for it to access the HDD, the registry and the internet just to install it. Even in the basic free firewall there seems to be lots more "security" now that makes clicking on the UACs look like child's play compared to this - And I had the interact with the human as little as possible box ticked!

    Did I miss some setting somewhere? Or is this now bloatware? I mean I love Comodo firewall, but this is unusable and I've had to uninstall it completely again and use Windows' firewall until I can get some idea what is going on? I am really hoping this is a bad version and the next one will be useable.

    Thanks for any help! I have run two different online antivirus scans and the laptop is coming up perfectly clean.

    Best wishes,


  2. #2
    WS Lounge VIP
    Join Date
    Jun 2010
    Thanked 1,421 Times in 1,232 Posts
    I think your best bet is to try Comodo's own support forums, given the nature of the problem, its repeatability and the fact that all seems due to a new version.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts