Results 1 to 3 of 3
  1. #1
    New Lounger
    Join Date
    Jul 2013
    Thanked 0 Times in 0 Posts

    Sharp drop in network speed on multi-hop SOHO - Win 7 64 bit

    I have a newly installed Acer Aspire X1420G with Windows Home Premium 64. This is a compact desktop computer with a 64 bit Athalon 3.10 GHz, 4 G Ram. I attached it to my existing home network via a hard wired connection to a nearby 10/100/1000 switch I have in the same room. I noticed that the upload and download speed to this computer were MUCH lower than a MAC Mini and a Thinkpad L420 (win 7 64 Professional) I have attached to the same switch.

    My home network consists of a DOCSIS 3.0 modem attached to a Netgear router which is attached via hard-wire to a centrally located 8-port 10/100/1000 switch in an upstairs room. The room I am working in has a wall outlet that is attached to the central switch. Inside this room is a second 8-port switch.

    The Acer gets about 20-25 Mbps downstream and 9-10 Mbps upstream on The Mac and the Thinkpad on the same switch get 70-75 Mbps downstream and 20-22 Mbps upstream on the same switch.

    I assumed I had a bad wire or switch port somewhere, so I swapped the Mac wiring with the Win7 Acer. - Same results

    I then tried getting everything else out of the picture and bypassed all the switches and other computers and just patched the Acer through to the modem - Then I got the same line rate as the Mac/Thinkpad - 70-75 down 20-22 up.
    I added the router / firewall back in - Acer and Mac and Thinkpad 70-75 down , 20-22 up.
    I added the central switch back - the line rates dropped only on the Acer. The Mac & Thinkpad were fine.
    I swapped the central switch from Netgear to D-Link - same problem.
    I swapped the local switch from Netgear to D-Link - same problem
    I tried all sorts of switch and wiring options. - same problem
    I took the Acer to a different room - same problem

    I tried upgrading the ethernet port drivers with the newest ones from Acer and from Nvidia - no change - still the same problem.
    I tried different speed test sites - it made no difference.
    I tried re-tuning the ethernet adapter setting on the Acer to change flow control, speed/duplex settings, wake from sleep, VLAN ID, interrupt moderation - no improvement

    I tried the tests with Google Chrome, Firefox and IE - same problem on the Acer with all three browsers.

    All the computers are fully up to date with the latest patches from Apple and Microsoft.

    So, basically, I have a 3-hop home network which works perfectly with a Mac Mini and a Thinkpad L420 and only works well in a one hop configuration with my Acer. I have tried about every fix I can come up with and nothing seems to work.

    I am looking for suggestions. If the best idea is to try a new Ethernet card, I would appreciate a recommendation that is known to work with an Acer Aspire X1420 desktop

  2. #2
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Manning, South Carolina
    Thanked 1,609 Times in 1,453 Posts

    Welcome to the Lounge as a new poster.

    Just a thought but are your switches powered? If not you may be hitting power problems with the extra computer. You could also possibly be hitting a total cable length problem. Have you tried only the Acer connected through all the wiring unhooking the other computers at the last switch? I'm just fishing here but it seems to me like it has to be something along this line since you get fine results when direct connected thus pretty much eliminating the machine itself. HTH
    May the Forces of good computing be with you!


    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  3. #3
    New Lounger
    Join Date
    Jul 2013
    Thanked 0 Times in 0 Posts
    Thanks for this idea, but I already ruled that out in several ways. I have moved the computer to other locations that I know work with other machines and swapped wiring and removed hops which shortens the effective length. I also tried working machines on the drop I use the Acer on.

    All the switches are powered. I don't know of any multi-port 10/100/1000 switches that are passive.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts