I have an application that writes a few files into a special folder under the Public folder on a win 7 64 computer. Well before that happens, the exe's startup code builds a path by querying Windows for standard folders, checks the path to see if it exists and then creates it if it does not. Here is the code that ultimately does this:

if !IsDir(lcAppInitPath)
md (lcAppInitPath)

This works fine, as you might expect of something simple that uses the exact same variable. This is immediately preceded by optional test code we can use to see the actual path on a user's computer if needed. The whole thing is in a error trapping structure that displays detailed error info.

The problem: On a new installation the code fails, returning a "A subdirectory or file... already exists" error right after the test code displays the (perfectly good) expected path. However, when we investigated we found two things: 1) The path did not actually exist, which explains why the MD command fired, but also 2) the Public folder on that PC was oddly inaccessible and not even shared. However, the user was set up as an administrator. We tried installing the system on one other Windows 7 PC on the network and all worked as expected. The "problem" PC was a virgin install of Win 7 while the second one was an upgrade from XP. The app is 32 bit and is running without problem on everything from XP to win 8.1.

My suspicions are that this workstation has been locked down more than necessary, but their IT person was not sure why it was behaving in the way we saw. Has anyone seen this before, or can tell if it is a symptom of a certain kind of setup? Thanks for any input...