Results 1 to 5 of 5
  1. #1
    Star Lounger
    Join Date
    Jul 2012
    Thanked 0 Times in 0 Posts

    Impossible to dual boot Windows 10 with Windows 8 - GPT partition style

    Hi all,

    I tried the usual dual boot scenario to test Windows 10, like I did with Windows 8, and Windows 7 years ago. It doesn't work! All the sites that explain how to do the dual boot are wrong, or only work on old systems.

    I'm trying to install from a USB stick. I get the message:

    "Windows can't be installed on this disk. Selected disk is of the GPT partition style."

    I searched all over the net for a solution. There is none. They all say to erase the whole disk, which um defeats the purpose. This is quite surprising to me since most recent laptops would be UEFI/GPT types, yet MS and Windows experts seem to be oblivious to this problem.

  2. #2
    WS Lounge VIP Coochin's Avatar
    Join Date
    Jun 2014
    Queensland, Australia
    Thanked 366 Times in 319 Posts
    Back in October 2014 I tried to dual-boot Win10TP with Win7. Had problems with chkdsk running whenever I tried to boot into Win7, but avoided that problem by turning off "Fast Startup" in Win10TP.

    Later ran into further problems dual-booting Win10TP and Win7 when my 2TB SATA HDD suddenly became inaccessible after I upgraded to Win10TP build 9879. Have since, with some difficulty, recovered my data from the 2TB HDD but had to replace that HDD with a new one as the affected HDD remained inaccessible.

    Have since banned Win10TP from my "main" (mission critical) system, and now am running it from a secondary system which will (hopefully) avoid any further such HDD problems.

    It seemed just TOO coincidental that my 2TB data HDD failed so soon after I installed the Win10TP 9879 upgrade. Note that the subject 2TB HDD remains inaccessible from any but the system in which it was originally installed; even in that system the HDD was listed in "Drive Management" as "not initialised". But I was able to recover the files from that HDD after booting from a BartPE boot CD, which did allow access to the NTFS partitions on the 2TB HDD, and I was able to copy the files to a backup HDD.

    Update 28/1/2015: see Fix for HDD problem caused by Win10TP build 9879 for details.
    Last edited by Coochin; 2015-01-27 at 18:04. Reason: update
    Computer Consultant/Technician since 1998 (first PC was Atari 1040STE in 1988).
    Most common computing error is EBKAC: Error Between Keyboard And Chairback
    Confuscius said: "no use running harder if you're on the wrong road" and "any problem once correctly understood is already half-solved".

  3. #3
    Administrator jwitalka's Avatar
    Join Date
    Dec 2009
    Thanked 822 Times in 737 Posts
    I am currently booting Windows 10 TP and Windows 7 without any problems. If my memory serves me correctly (and at 72 that may not be a given), in the first build I had to set up BIOS to boot from the Windows 10 disk and then use Easy BCD to add in Windows 7. Ever since I haven't had any dual boot issues or have any need to disable fast boot. I've gone through every new boot without any additional problems. This is on an MBR system. GPT obviously could have additional issues.

    I did notice that for the first time, Windows 10 has added a Windows Rollback to the boot menu with this build. That gives me three options - Windows 7, windows 10, and Windows Rollback.


  4. #4
    3 Star Lounger
    Join Date
    Dec 2009
    Skelmersdale, Lancashire, UK
    Thanked 10 Times in 10 Posts
    I also am currently booting Windows 10 TP and Windows 7 without any problems. I was already dual booting W7 with W8.1 and used the upgrade install method for W10. I had to use EBCD to sort out the boot sequence to my liking, but W10 had already provided a dual boot blue screen with an additional option for rolling back as well. I kept that, but generally prefer to use Acronis images, which I make regularly.

  5. #5
    2 Star Lounger
    Join Date
    Dec 2009
    Thanked 15 Times in 14 Posts
    I had the same problem. I had used the Win 7 USB/DVD tool to create my iso and received the same message as you did. I forget how I worded my google search but found a solution immediately.
    The Win 7 tool created the iso as an mbr, which will not install to gpt. If you download Rufus there is a dropdown box, I believe the second from top, to create the iso for installing to a gpt disk. Again, I forget the exact wording but it's obvious.
    Second attempt worked like a charm.
    ‎5000 years ago, Moses said 2 Israel, "Pick up your shovels, mount your asses & camels, & I will lead you 2 the Promised Land." When Welfare was introduced, Roosevelt said, "Lay down your shovels, sit on your asses, & light up a Camel, this is the Promised Land." Now the government has stolen your shovel, taxed your asses, raised the price of Camels & mortgaged the Promised Land to China

    Reply With Quote Reply With Quote

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts