Results 1 to 3 of 3
  1. #1
    3 Star Lounger
    Join Date
    Jan 2001
    San Francisco, California, USA
    Thanked 0 Times in 0 Posts

    Running my own macros in Word 10

    Microsoft is saving me from myself again. I'm at my wit's end.

    I have Word 2010 installed. I wrote some VB code to make my life easier. But every time I try to run it, I get a message saying that the macros in this project are disabled, check online help yada yada yada. The online help is useless because the help refers to a yellow bar that I NEVER get to see. And before you ask, YES, I do have "Show the Message Bar" enabled in the Trust Center. Here's what else I've done:

    I tried creating a self certification. It didn't help, all it did was "protect" my document until the next time I edited it, then it told me my document was unsafe because it had been edited. Some big help, eh?

    I added every folder I could think of to "Trusted locations" in the trust center. I even included subfolders. Although I only have one document in one folder. But this has not helped one bit.

    Under "Trusted Documents" I took the risky act of trusting all my documents on my network. Since I'm the only user on my network and I'm behind a both a hardware firewall and M$'s own firewall, there is zero risk there, but yet I had to take it.

    Nothing is checked under Add-ins. I don't have any at the moment, and after this experience, I doubt I ever will.

    Under Active X, I have everything enabled even thought I'm told this is super risky. Oh well. It didn't help anyway.

    Under Macro Settings I checked the super risky Enable All Macros. Now why doesn't this help? I am so flabbergasted that this was not the answer to my being able to run the ONLY macro that I have, that I wrote with my own hands and brain!?!

    I didn't change anything under Protective View. Well, at one point I did, but I must've put it back. Because Data Execution Prevention mode is checked, although I don't think it's necessarily necessary.

    What else should I be doing? I didn't realize that if I wrote my own code that I could bring down my whole network and that of the entire country. Then why give us the ability to write code at all? Sorry for the snottyness but I'm really frustrated and frankly p-d off at microsoft.

    Side note: I did, on several occasions, manage to get my code to run successfully, but every time I seem to go through this same frustration, like Microsoft is purposefully changing something on me to prevent me from running my own code. I've run out of things to check and am so cross-eyed I couldn't see it even if it was there.

    Can someone help?



  2. #2
    Super Moderator
    Join Date
    Jan 2001
    Melbourne, Victoria, Australia
    Thanked 295 Times in 267 Posts
    Where is the macro saved? Is it in a document or a template?
    Andrew Lockton, Chrysalis Design, Melbourne Australia

  3. #3
    Silver Lounger Charles Kenyon's Avatar
    Join Date
    Jan 2001
    Sun Prairie, Wisconsin, Wisconsin, USA
    Thanked 128 Times in 123 Posts
    Word 10 was Word 2002, Word 11 was Word 12, Word 2010 is Word 14. Confused?
    I assume you mean Word 2010.

    On your Trust Center settings under Developer Macro Settings, do you have "Trust access to the vba project object model" checked?

    Under Trusted Locations, at the bottom of the dialog, do you by any chance have "Disable All Trusted Locations" checked?

    Under Trusted Documents, do you by chance have the box checked to "Disable Trusted Documents?"

    I run my system set to disable macros after notification. This gives me a button that lets me enable macros that would not otherwise run.

    This likely has nothing to do with Add-Ins. Many are very useful. The few that cause problems are usually .com or .dll add-ins. I have not heard of any causing your problem.
    Last edited by Charles Kenyon; 2015-03-11 at 06:59.
    Charles Kyle Kenyon
    Madison, Wisconsin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts