Results 1 to 2 of 2
  1. #1
    2 Star Lounger
    Join Date
    Dec 2001
    Houma, Louisiana, USA
    Thanked 0 Times in 0 Posts

    Can't run search

    Yesterday I installed a number of programs on my computer and in the evening when I tried to use search to find some files, I got the following message:

    "A file that is required to run Search Companion cannot be found. You may need to run setup."

    Now I can't use Search at all.
    First I went to add/remove programs and checked the windows componets, but there's nothing there for removing or reinstalling search. Then I tried putting in the setup disks (Toshiba recovery) that came with my computer. There are 2 options.
    1)Install applications and drivers OR
    2)Restore the original default system setup
    I tried option 1, but don't see windows components under the list of applications to install. I looked at option 2 and it says it will delete everything and restore the original system setup. I have put in way too much time configuring the system to have to start all over.

    So now I'm stuck. I can't live without search because I have files stored all over the place. I need search to find them all and reorganize my data. Can anyone give me suggestions about what to try next? I'm using XP home edition on a Toshiba Satellite 1805-254.

  2. #2
    New Lounger
    Join Date
    Oct 2001
    Chapel Hill, NC
    Thanked 0 Times in 0 Posts

    Re: Can't run search

    I would suggest visiting and searching for "Search Companion" (use quotes). There are numerous posts concerning people whose search companion has "broken". I found this because I was experiencing problems with the "Search Companion" in Windows XP Explorer while trying to look for a word or phrase in all files on a disk -- it actually only looks in files registered with the OS as searchable. Knowledge Base article Q309173 (at states that this is by design in XP in order to speed up the Indexing Service and thus the Search Companion. Even if you have the indexing service turned off, it will only search in registered files.

    I was trying to seach for VB files (.Bas) with a certain phrase and the OS would not show any files in the results, even though I knew the files had the text in them (.Bas files are plain text, not binary). The KB articles states that the October 25, 2001 compatibilty update fixes this for numerous files, but .Bas files are not one of them. In order to add searchability of non-registered files you must edit the registry to add a key like the following:

    HKEY_CLASSES_ROOT.BasPersistentHandler(Default) = {5e941d80-bf96-11cd-b579-08002b30bfeb}

    This kind of "bug" can be really frustrating the first time you encounter it. Try the following to re-create the behavior:

    Create a folder named 'c:temp'
    Create a file 'test.txt' in c:temp which contains some random characters and the word Microsoft
    Copy the file test.txt 4 times in the same directory c:temp
    Change the extensions of the 4 copies to .wav .doc .mdb .cpp

    Now the folder contains 5 copies of the SAME file with different extension

    Try now to search c:temp for (all files and folders) which CONTAIN the word Microsoft and you'll see only the .txt and .cpp files.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts