Results 1 to 6 of 6
  1. #1
    New Lounger
    Join Date
    Aug 2014
    Thanked 0 Times in 0 Posts

    Corrupt recycle bin in Windows XP?

    Windows XP Home, Sp3. (Spare computer for emergency use and which contains programs which will not operate in Windows 7).

    If I open the recycle bin, there is nothing there.

    If I try to empty the recycle bin, the message asks "Are you sure you want to delete these 8 items ?".

    If I say "yes", I get an "error deleting file or folder" message which states "cannot delete filterpipelineprintproc: Access is denied. Make sure the disk is not full or write protected and that the file is not currently in use".

    I ran Avast, Malwarebytes, AdAware and Chkdsk. All OK.

    Microsoft Fixit had to shut down because of a problem, but I seem to remember it doing that in the past with other computers.

    Folder options is set to "Show hidden files, folders and drives". "Hide protected operating system files" is unchecked.

    The recycle bin shows empty with 0 objects and 0 bytes, but if I check "empty recycle bin", it states 8 items. If I proceed with "empty", it says it cannot delete filterpipelineprintproc. If I add a file to the recycle bin, it then shows 9 files. It will delete the added file but then says it cannot delete filterpipelineprintproc.

    Filterpipelineprintproc appears several times in C: I thought this was automatically deleted in a system update or something like that? A Google search seems to say that it shouldn't be there, but not sure. Don't know why it seems to be connected with the recycle bin.

    It seems as though there are two issues (maybe related?): Corrupt recycle bin and the appearance of the filterpipelineprintproc file.

    Using the command rd /s I tried to remove the recycler folder from all drives and then reboot. When it came to the external hard drive, it would not remove many files because of protection. Thinking that removing the external drive might solve the problem, I removed it and rebooted. Then the recycle bin would not work at all because the commands were greyed out. Another odd thing is that after all but the external drive were reset, the number of files indicated in the recycler were 2 and not 8. When I plugged the external drive back in, the recycle bin commands were present, but it wouldn't delete the filterpipelineprintproc file. Why won't the recycle bin function when the external drive is unplugged?

    I did a search of all files and folders and found that filterpiplineprintproc.dll appears 13 times. Six of those are in C:. Many are in the external drive. Maybe these are the cause of the recycle bin behavior. Can I delete them?

    I would appreciate your help in solving this problem.

  2. #2
    5 Star Lounger
    Join Date
    Nov 2010
    Thanked 31 Times in 29 Posts
    Have you tried running chkdsk /f on the external drive?

  3. #3
    WS Lounge VIP Calimanco's Avatar
    Join Date
    Dec 2009
    Bradford UK
    Thanked 168 Times in 149 Posts

  4. #4
    4 Star Lounger
    Join Date
    Jun 2011
    Hampshire (the old one)
    Thanked 78 Times in 67 Posts
    Quote Originally Posted by Calimanco View Post
    You'll have to do that in Safe Mode, OP. It's the only way to stop Simple File Sharing in Home Edition.

  5. #5
    Restart your computer. At the Windows startup screen, press the F8 key. Several options will appear on your screen. Select "Safe Mode with Command Prompt." Your screen should now show a command prompt, or "C:\." If you see something else, you may be in the Windows directory. Type the command "CD\" and press Enter. This should bring you to "C:\."

    Type "attrib --s --h recycler" and press Enter. This command tells Windows to give you access to the protected file.

    Type the command "del recycler" and press Enter. This entry will delete your corrupt Recycle Bin.

    Restart your computer. Windows will detect the missing Recycle Bin and create a new one.
    Last edited by kaufen; 2015-10-05 at 07:22.

  6. #6
    New Lounger
    Join Date
    Feb 2014
    Thanked 0 Times in 0 Posts
    I am experiencing a problem very similar. On an old XP desktop system I have the original drive that now servers as a secondary drive, used to archive data. Recently went through deleting as many files as I could to make room for the large amount of pictures I wanted to archive. When I went to empty the recycle bin all the files disappeared but I got an error message "Error Deleting File or Folder" Cannot remove folder Df899: Access is denied. Make sure the disk is not full or write protected and that the file is not currently in use.

    There are no visible files in the recycle bin and the folder view is set to show all hidden files and folders. A search for "Df899" yields a folder Df899 with a path of: F:\RECYCLER\S-1-21-3327.................. on and on.

    Tried the "attrib --s --h recycler" thing above, system took a very long time to restart, constant disk churn and a message that an update was being installed and not to turn off the computer. Several minutes later the system restarted and nothing changed.

    If I go to F:\RECYCLER I can see the "S-1-21-3327.................. on and on". If I right click and choose Properties, General, I see the file is check as Read-only. When I uncheck that and click apply, the check mark disappears until I check the properties again and see the the Read-only checked again. Of course deleting the file here again yields the same error message.

    It is not crucial that I rectify this, but I would like to clear out this issue if I can. Any additional suggestions would be appreciated.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts