Results 1 to 4 of 4
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Thanked 0 Times in 0 Posts

    10586.3 Update and disappearing NAS device.

    Did the upgrade to 10586.3 last night. Everything went smoothly. Took about 2 hours all told. The upgrade deleted Speccy, explaining it is not compatible. I expect Piriform will address that soon. Most troubling is that my NAS device, a 3TB Western Digital with 3 main shares, is no longer visible in Network. I can address the device by its IP address, and for the moment I've mapped those shares in This PC by their IP and names (Video ( (My Book Live Network Storage))).

    Browsing Google I see I'm not alone. I've tried most of the recommended fixes with no luck. Any ideas would be greatly appreciated.

  2. #2
    New Lounger
    Join Date
    Jun 2010
    Thanked 0 Times in 0 Posts
    I have exactly he same problem with both a WD MyBookLiveDuo and a Synology DS213j.
    As mixz1 reports, File Explorer refuses to display the NAS devices as Computers as prior to the update.
    It will (usually and often after some while) display them under Other devices (Synology) and Storage (WD).
    Clicking on them of course only gets you to the device web page.
    I can type the "ipaddress" eg \\DISKSTAION in the address bar and it will them place the device on the left hand pane and I can navigate to the shared folders from there.
    Command files can happily resolve the full address of shared folders even though File Explorer cannot.

    I have tried Google found suggestions including:
    1. Checking in "Turn Windows features on or off" that SMB 1.0/CIFS File Sharing Support is turned on (it was)
    2. Run sfc /scannow - no errors found
    3. run DISM - again no errors found

    Is there anybody out there watching who has NOT had this problem?

    Setup is Windows 10 Home upgraded from OEM Windows 8.1
    Intel I5 with 4gb in Fujitsu laptop.

  3. #3
    WS Lounge VIP Coochin's Avatar
    Join Date
    Jun 2014
    Queensland, Australia
    Thanked 366 Times in 319 Posts
    I don't have NAS but have several computers in a workgroup. After the 10586.3 upgrade installed on my two Win10 systems my Win7 computers are not shown in Network in File Explorer.

    Computer Consultant/Technician since 1998 (first PC was Atari 1040STE in 1988).
    Most common computing error is EBKAC: Error Between Keyboard And Chairback
    Confuscius said: "no use running harder if you're on the wrong road" and "any problem once correctly understood is already half-solved".

  4. #4
    Super Moderator bbearren's Avatar
    Join Date
    Dec 2009
    Polk County, Florida
    Thanked 450 Times in 356 Posts
    I have a Seagate 3TB NAS, and also a Windows 10 PC that I've configured as a NAS/File Server with 4 3TB Seagate NAS hard drives in a RAID 10 array that gives me 5.45TB striped/mirrored storage.

    They both show up in Network in File Explorer. I don't use Home Group, I use workgroup networking. Also in Network and Sharing Center > Advanced sharing settings I have "Use user accounts and passwords to connect to other computers" checked, and not "Allow Windows to manage homegroup connections (recommended)".

    I have Homegroup Provider and Homegroup Listener both disabled in Services.
    Create a fresh drive image before making system changes, in case you need to start over!

    "The problem is not the problem. The problem is your attitude about the problem. Savvy?"—Captain Jack Sparrow "When you're troubleshooting, start with the simple and proceed to the complex."—M.O. Johns "Experience is what you get when you're looking for something else."—Sir Thomas Robert Deware.
    Unleash Windows

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts