Results 1 to 5 of 5
  1. #1
    New Lounger
    Join Date
    Sep 2011
    Thanked 0 Times in 0 Posts

    Undetermined Windows/Media Playing Issues: How to hunt for corrupt system files?

    I have been having all kinds of weird issues with my laptop for months now. I have been trying to schedule a re-install, which I have never done before, but part of me just CANNOT give up on trying to find the cause of the issues
    FYI: I am running 64-bit Windows 7 Pro on a Dell M6600 with 8GB of memory, booting off a 126GB SSD with a 750GB hybrid data drive.
    It would seem there are multiple issues, but the major one is that (up until recently) I could no longer play any videos on my system. Any video player would blow out attempting to play any type of video file. I normally use VLC but also tried Windows Media Player and other Video tools that I have (Adobe, Nero, etc). All would blow out with the generic Windows Error "<Program_Name> has stopped working.".

    One of the things I did recently is run the "System File Checker" (sfc) with the "\scannow" option. After digging through the log file, I discovered that sfc found (and "fixed") 4 corrupt media .dll files. The lines from the log file are as follows:
    Repairing corrupted file [ml:520{260},l:46{23}]"\??\C:\Windows\System32"\[l:30{15}]"msmpeg2adec.dll" from store
    Repairing corrupted file [ml:520{260},l:46{23}]"\??\C:\Windows\System32"\[l:30{15}]"msmpeg2vdec.dll" from store
    Repairing corrupted file [ml:520{260},l:46{23}]"\??\C:\Windows\System32"\[l:28{14}]"MSMPEG2ENC.DLL" from store
    Repairing corrupted file [ml:520{260},l:46{23}]"\??\C:\Windows\System32"\[l:36{18}]"DShowRdpFilter.dll" from store
    Once this was done Windows Media Player could play some video files, but VLC still would not play any and always blew out. I uninstalled VLC, re-installed it, uninstalled, installed the 32-bit version, un-installed again, ran CCLeaner, re-installed the 64-bit version. It just keeps blowing out on every media file.

    One of the other, and I'm sure related, issues, is that I have one directory with some video files in it, and if I navigate into this directory with Windows Explorer, W.E. blows out with the generic error: "Windows Explorer has stopped working".

    I believe the issue is due to Windows remembering this folder wants the "Length" column displayed (as in the play length of the media file). Now, if I rename 2 specific files (with a different file manager), so that windows does not know what file type they are, then W.E does not blow out at this directory. The extensions of these files are ".ts" and ".mpg". The files that do not make IE blow out are .mp4 files (among other non-media files). All three of these extensions are (currently) associated with Windows Media Player. And, if I navigate to this directory without the "Length" column displayed, then I can double click any of the files and Windows media Player will play them. So, the issue seems to be with the process that W.E. uses to determine the "Play Length" of the 2 specific media file types: .ts and .mpg. It is obviously not using the same decoder file that Windows Media Player is using as WMP plays the files just fine (but VLC will not at all).

    I've had been scouring the Internet looking for a good way to "re-install all audio/video codecs" but I have not found anything so far.

    If anyone understands the process that W.E. uses to extract the play length, or why VLC will no longer play ANY media file let me know. I have used VLC for years and it's been, great. I even used process explorer to make a list of every dll that WMP and VLC loaded thinking I could easily determine the problem files VLC was using but it looks like VLC loads every dll on my whole system! WMP loaded 190 dlls but VLC loaded 486!


  2. #2
    WS Lounge VIP Coochin's Avatar
    Join Date
    Jun 2014
    Queensland, Australia
    Thanked 367 Times in 320 Posts
    Quote Originally Posted by NomadicWolf View Post
    ...I've had been scouring the Internet looking for a good way to "re-install all audio/video codecs" but I have not found anything so far...
    K-Lite MEGA Codec Pack:

    Includes "Media Player Classic" (excellent for videos) and checks for bad codecs.
    Computer Consultant/Technician since 1998 (first PC was Atari 1040STE in 1988).
    Most common computing error is EBKAC: Error Between Keyboard And Chairback
    Confuscius said: "no use running harder if you're on the wrong road" and "any problem once correctly understood is already half-solved".

  3. #3
    Since you mentioned "all kinds of weird issues", I would run a System Health report in Performance Monitor...

    In a Run prompt, type perfmon /report

    I would also take a look at what kinds of errors Windows has logged...

    In Control Panel, navigate to Administrative Tools and click on Event Viewer.

    Expand the Custom Views folder and click on Administrative Events.

    The Administrative Events contain Warnings, Errors, and Critical events from all event logs.

  4. #4
    Super Moderator
    Join Date
    Aug 2012
    Durham UK
    Thanked 1,048 Times in 996 Posts
    I have a couple of fixes for WMP you could try if K-Lite doesn't do it for you.

    And then run through these

  5. #5
    New Lounger
    Join Date
    Sep 2011
    Thanked 0 Times in 0 Posts
    Well, I don't know why this worked, but VLC now works. Here is what I did.

    I took the suggestion to go back and look through my Event Viewer for errors. I have done this before, and there are errors, but nothing I thought would relate to a video playing issue, but I thought I would pursue some of these errors.
    The first error I came to was as follows:

    “The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID {C97FCC79-E628-407D-AE68-A06AD6D8B4D1} and APPID {344ED43D-D086-4961-86A6-1106F4ACAD9B}
    to the user NT AUTHORITY\LOCAL SERVICE SID (S-1-5-19) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool. ”

    This "AppID" is for the "IPBusEnum" service (like I thought that would relate to video playback. ???)

    I did an Internet search on this whole error string and found the following link and I followed all the steps:

    And then VLC would play all videos. Go figure.

    While I had used Perfmon in the past for logging different metrics and looking for performance issued, I was unaware of the "/report" option. When I tried running "perfmon /report" yesterday it just hung and never came back. Today it generated a long report that I am still sifting through.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts