Results 1 to 3 of 3
  1. #1
    New Lounger
    Join Date
    Dec 2015
    Thanked 0 Times in 0 Posts

    Crash attempting to run Age of Empires III on Windows 10

    First, yes, I do have a legitimate copy.I installed the three disks without any issues, but upon completing the installation process I relaunch the disk and hit play. It displays the loading splash screen then it crashes out with the following message:Age Of Empires 3 Has Stopped WorkingA problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is found [Debug] [Close program].I have tried updating my graphics drivers and loading with (no video).I have tried running compatability settings.I have tried reinstalling many times with a clean install using CCleaner.I ripped the disk and mounted as an iso(appears to work, but same error).Many restarts.It was working on monday night, but tuesday evening when I went to use it, it no longer loaded. No programs were installed or changed, and no updates were installed. Settings are also unchanged. This really confuses me. Am I missing something? Many sites claim it's a compatibility issue with win 7+, but I would think compatability settings would fix that.upon attempting to debug I found this although it appears it may simply be an issue with the visual studio debugger and not the program:Unhandled exception at 0x745D164E (msvcrt.dll) in age3.exe: 0xC000041D: An unhandled exception was encountered during a user callback.

  2. #2
    5 Star Lounger
    Join Date
    Jan 2010
    Los Angeles, CA
    Thanked 38 Times in 34 Posts
    The problem is with the digital rights management (DRM) software used to prevent piracy. Apparently, all of the old Microsoft game titles and many other titles relied on a DRM DLL which verified that you indeed had a legal copy of the software before running it. That's why you have to have the CD/DVD in the drive before you can play the game, the DRM DLL checked the disk to make sure it had the expected layout. Anyway, at some point in time a KB update from Microsoft removed the DLL form various versions of Windows, and of course that DLL doesn't come with Windows 10. So that is why you are getting an error - the game is attempting to use the DLL that doesn't exist.

    According to my reading, getting the DLL is problematic and doesn't appear to work anyway (probably needs to be installed in some fancy way, not just copied to disk). So the best solution I have found is to get a "no-CD" patch - this is a replacement to the EXE file that runs the game where the code to check the CD (the code which relies on the DLL being there) has been removed. I currently have such patches for almost every old game that I have (I keep meticulous notes on what is required to run all of my old games, I still play a lot of them in Windows 10). The best place I have found to download the patch for AoE III is, this looks like the official support site for AoE III, it provides a lot of game updates, so there should be no security issues such as are present on other sites of this kind.

  3. The Following User Says Thank You to cafed00d For This Useful Post:

    Lugh (2016-06-11)

  4. #3
    5 Star Lounger Lugh's Avatar
    Join Date
    Jun 2010
    Thanked 109 Times in 96 Posts
    Useful info Cafe, thanks. However, Villain said...
    Quote Originally Posted by The Villain In Glasses View Post
    It was working on monday night
    ...which suggests it's some intermittent problem, not an always problem like DRM failure.

    Villain, to clarify, you were able to launch, play and exit normally on Monday night, is that right?

    tuesday evening when I went to use it, it no longer loaded
    Are you quite sure Windows couldn't have performed a stealth update between Mon & Tues? Try turning off whatever other non-essential programs are running, before launching AoE. Set your resolution to one which AoE supports [probably 1024x768]. If you have 2+ monitors installed, disable all except the game one.

    I have tried running compatability settings
    Try installing while in an administrator account, and also running as admin [belt & braces ], and confirm you have the DirectX version it needs [probably DX9].

    I think the best general approach for older games is:
    Cafe's no-CD advice;
    Compatibility mode;
    A few old virtual OS's, eg 98, XP, 7.
    I doubt MS will be testing Win10 updates on older games before forcing them onto PCs, so a few virtual machines could be the lowest hassle solution if the game isn't available on GOG.
    Dell Alienware Aurora R6 (new 2017)
    Windows 10 Home x64 1703; Office 365 x32
    GeForce GTX 1060; 16GB DDR4 2400
    256G SSD, 1TB HD

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts